CVE-2019-15717
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
- Record
CVE-2019-15717- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
- Record
CVE-2019-15717- Updated
- 2026-11-02
EUVDEUVD-2019-6653 No score
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
- Record
EUVD-2019-6653- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gx32-945w-w9x4
9.8
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
- Record
GHSA-gx32-945w-w9x4- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSVALPINE-CVE-2019-15717
9.8
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
- Record
ALPINE-CVE-2019-15717- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSV
9.8
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
- Record
CVE-2019-15717- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-15717
9.8
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP.
- Record
DEBIAN-CVE-2019-15717- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2019-0255 No score
Updated irssi packages fix security vulnerability
Updated irssi packages fix security vulnerability:
Irssi 1.2.x before 1.2.2 has a use-after-free if the IRC server sends a double CAP (CVE-2019-15717).
- Record
MGASA-2019-0255- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10865-1 No score
irssi-1.2.3-2.4 on GA media
These are all security issues fixed in the irssi-1.2.3-2.4 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10865-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
irssiAlpine:v3.10 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.11 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.12 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.13 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.14 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.15 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.16 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.17 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.18 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.19 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
Show 10 moreShow less
| Package | Affected | Fixed |
|---|---|---|
irssiAlpine:v3.20 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.21 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.22 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.23 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiAlpine:v3.24 |
1.2.0 up to 1.2.2-r0 | 1.2.2-r0 |
irssiDebian:12 |
before 1.2.2-1 | 1.2.2-1 |
irssiDebian:13 |
before 1.2.2-1 | 1.2.2-1 |
irssiDebian:14 |
before 1.2.2-1 | 1.2.2-1 |
irssiMageia:7 |
before 1.2.2-1.mga7 | 1.2.2-1.mga7 |
irssiopenSUSE:Tumbleweed From an advisory covering 26 CVEs |
before 1.2.3-2.4 | 1.2.3-2.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-15717 is a critical vulnerability (CVSS 9.8) in Irssi, published August 29, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.49%, the 84th percentile. Fixed in irssi 1.2.2-r0.
References
irssi.org/security/irssi_sa_2019_08.txt
openwall.com/lists/oss-security/2019/08/29/3
openwall.com/lists/oss-security/2019/08/29/5
usn.ubuntu.com/4119-1
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JDDRTNKDDO52CO5USJ73BE6XVG7BD4KP
nvd.nist.gov/vuln/detail/CVE-2019-15717
Show 31 moreShow less
github.com/advisories/GHSA-gx32-945w-w9x4
security.alpinelinux.org/vuln/CVE-2019-15717
security-tracker.debian.org/tracker/CVE-2019-15717
advisories.mageia.org/MGASA-2019-0255.html
bugs.mageia.org/show_bug.cgi?id=25388
suse.com/security/cve/CVE-2017-10965
suse.com/security/cve/CVE-2017-10966
suse.com/security/cve/CVE-2017-15227
suse.com/security/cve/CVE-2017-15228
suse.com/security/cve/CVE-2017-15721
suse.com/security/cve/CVE-2017-15722
suse.com/security/cve/CVE-2017-15723
suse.com/security/cve/CVE-2017-5193
suse.com/security/cve/CVE-2017-5194
suse.com/security/cve/CVE-2017-5195
suse.com/security/cve/CVE-2017-5196
suse.com/security/cve/CVE-2017-5356
suse.com/security/cve/CVE-2017-9468
suse.com/security/cve/CVE-2017-9469
suse.com/security/cve/CVE-2018-5205
suse.com/security/cve/CVE-2018-5206
suse.com/security/cve/CVE-2018-5207
suse.com/security/cve/CVE-2018-5208
suse.com/security/cve/CVE-2018-7050
suse.com/security/cve/CVE-2018-7051
suse.com/security/cve/CVE-2018-7052
suse.com/security/cve/CVE-2018-7053
suse.com/security/cve/CVE-2018-7054
suse.com/security/cve/CVE-2019-13045
suse.com/security/cve/CVE-2019-15717
suse.com/security/cve/CVE-2019-5882