CVE-2019-16058
An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC. If a smart card...
An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC. If a smart card creates a signature with a length longer than 256 bytes, this triggers a buffer overflow. This may be the case for RSA keys with 4096 bits depending on the signature scheme.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC. If a smart card creates a signature with a length longer than 256 bytes, this triggers a buffer overflow. This may be the case for RSA keys with 4096 bits depending on the signature scheme.
- Record
CVE-2019-16058- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC. If a smart card creates a signature with a length longer than 256 bytes, this triggers a buffer overflow. This may be the case for RSA keys with 4096 bits depending on the signature scheme.
- Record
CVE-2019-16058- Updated
- 2026-11-02
EUVDEUVD-2019-6921 No score
An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC. If a smart card creates a signature with a length longer than 256 bytes, this triggers a buffer overflow. This may be the case for RSA keys with 4096 bits depending on the signature scheme.
- Record
EUVD-2019-6921- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2pqr-cp8m-m5vw
7.5
An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC. If a smart card...
An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC. If a smart card creates a signature with a length longer than 256 bytes, this triggers a buffer overflow. This may be the case for RSA keys with 4096 bits depending on the signature scheme.
- Record
GHSA-2pqr-cp8m-m5vw- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-119
- Updated
- 2026-11-02
OSV
7.5
An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC. If a smart card creates a signature with a length longer than 256 bytes, this triggers a buffer overflow. This may be the case for RSA keys with 4096 bits depending on the signature scheme.
- Record
CVE-2019-16058- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-16058
7.5
An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC. If a smart card creates a signature with a length longer than 256 bytes, this triggers a buffer overflow. This may be the case for RSA keys with 4096 bits depending on the signature scheme.
- Record
DEBIAN-CVE-2019-16058- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-16058
7.5
An issue was discovered in the pam_p11 component 0.2.0 and 0.3.0 for OpenSC. If a smart card creates a signature with a length longer than 256 bytes, this triggers a buffer overflow. This may be the case for RSA keys with 4096 bits depending on the signature scheme.
- Record
UBUNTU-CVE-2019-16058- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11143-1 No score
pam_p11-0.3.1-1.2 on GA media
These are all security issues fixed in the pam_p11-0.3.1-1.2 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11143-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pam-p11Debian:12 |
before 0.3.1-1 | 0.3.1-1 |
pam-p11Debian:13 |
before 0.3.1-1 | 0.3.1-1 |
pam-p11Debian:14 |
before 0.3.1-1 | 0.3.1-1 |
pam-p11Ubuntu:14.04:LTS |
All versions, plus listed versions 0.1.5-2ubuntu10.1.5-30.1.5-3ubuntu1 |
None known |
pam-p11Ubuntu:16.04:LTS |
All versions, plus listed versions 0.1.5-3ubuntu10.1.5-4 |
None known |
pam-p11Ubuntu:18.04:LTS |
All versions, plus listed versions 0.1.6-20.1.6-2.1build10.1.6-2.1build20.1.6-3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-16058 is a high vulnerability (CVSS 7.5) in Opensc Project Opensc, published September 6, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.53%, the 74th percentile. Fixed in pam-p11 0.3.1-1.
References
github.com/OpenSC/pam_p11/commit/d150b60e1e14c261b113f55681419ad1dfa8a76c
openwall.com/lists/oss-security/2019/09/12/1
nvd.nist.gov/vuln/detail/CVE-2019-16058
github.com/advisories/GHSA-2pqr-cp8m-m5vw
security-tracker.debian.org/tracker/CVE-2019-16058
ubuntu.com/security/CVE-2019-16058
cve.org/CVERecord?id=CVE-2019-16058
suse.com/security/cve/CVE-2019-16058