CVE-2019-17671
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the...
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.3
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
- Record
CVE-2019-17671- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
- Record
CVE-2019-17671- Updated
- 2026-11-02
EUVDEUVD-2019-7976 No score
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
- Record
EUVD-2019-7976- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q76h-h683-9cc8
5.3
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the...
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
- Record
GHSA-q76h-h683-9cc8- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSV
5.3
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
- Record
CVE-2019-17671- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-17671
5.3
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
- Record
DEBIAN-CVE-2019-17671- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-17671
5.3
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
- Record
UBUNTU-CVE-2019-17671- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressDebian:12 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:13 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:14 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:8 From an advisory covering 4 CVEs |
before 4.1.28+dfsg-0+deb8u1, plus listed versions 4.1+dfsg-14.1+dfsg-1+deb8u14.1+dfsg-1+deb8u104.1+dfsg-1+deb8u114.1+dfsg-1+deb8u12 Show 18 moreShow less4.1+dfsg-1+deb8u134.1+dfsg-1+deb8u144.1+dfsg-1+deb8u154.1+dfsg-1+deb8u164.1+dfsg-1+deb8u174.1+dfsg-1+deb8u184.1+dfsg-1+deb8u24.1+dfsg-1+deb8u34.1+dfsg-1+deb8u44.1+dfsg-1+deb8u54.1+dfsg-1+deb8u64.1+dfsg-1+deb8u74.1+dfsg-1+deb8u84.1+dfsg-1+deb8u94.1.1+dfsg-14.1.25+dfsg-1+deb8u14.1.26+dfsg-1+deb8u14.1.27+dfsg-0+deb8u1 |
4.1.28+dfsg-0+deb8u1 |
wordpressDebian:10 From an advisory covering 18 CVEs |
before 5.0.4+dfsg1-1+deb10u1, plus listed versions 5.0.4+dfsg1-1 |
5.0.4+dfsg1-1+deb10u1 |
wordpressUbuntu:16.04:LTS |
All versions, plus listed versions 4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1 |
None known |
wordpressUbuntu:18.04:LTS |
All versions, plus listed versions 4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | WordPress Core < 5.2.3 - Viewing Unauthenticated/Password/Private Posts | 2019-10-14 |
| PoC in GitHub | rhbb/CVE-2019-17671 | 2020-04-03 |
| Nuclei | WordPress <= 5.2.4 - Unauthenticated View Private/Draft Posts |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, exploits, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, Nuclei, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-17671 is a medium vulnerability (CVSS 5.3) in Wordpress, published October 17, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 36.5%, the 98th percentile. Fixed in wordpress 5.2.4+dfsg1-1.
References
wpvulndb.com/vulnerabilities/9909
blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
wordpress.org/news/2019/10/wordpress-5-2-4-security-release
core.trac.wordpress.org/changeset/46474
github.com/WordPress/WordPress/commit/f82ed753cf00329a5e41f2cb6dc521085136f308
lists.debian.org/debian-lts-announce/2019/11/msg00000.html