Every CVE Search/ Get API key

CVE-2019-18182

pacman before 5.2 is vulnerable to arbitrary command injection in conf.c in the...

9.8 CriticalFix available

pacman before 5.2 is vulnerable to arbitrary command injection in conf.c in the download_with_xfercommand() function. This can be exploited when unsigned databases are used. To exploit the vulnerability, the user must enable a non-default XferCommand and retrieve an attacker-controlled crafted database and package.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.67%Up 2.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

pacman before 5.2 is vulnerable to arbitrary command injection in conf.c in the download_with_xfercommand() function. This can be exploited when unsigned databases are used. To exploit the vulnerability, the user must enable a non-default XferCommand and retrieve an attacker-controlled crafted database and package.

Record
CVE-2019-18182
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-78
Updated
2026-11-02
CVE List No score

pacman before 5.2 is vulnerable to arbitrary command injection in conf.c in the download_with_xfercommand() function. This can be exploited when unsigned databases are used. To exploit the vulnerability, the user must enable a non-default XferCommand and retrieve an attacker-controlled crafted database and package.

Record
CVE-2019-18182
Updated
2026-11-02
EUVDEUVD-2019-7987 No score

pacman before 5.2 is vulnerable to arbitrary command injection in conf.c in the download_with_xfercommand() function. This can be exploited when unsigned databases are used. To exploit the vulnerability, the user must enable a non-default XferCommand and retrieve an attacker-controlled crafted database and package.

Record
EUVD-2019-7987
Updated
2026-11-03
GitHub AdvisoriesGHSA-f94h-gmg7-c6gw No score

pacman before 5.2 is vulnerable to arbitrary command injection in conf.c in the...

pacman before 5.2 is vulnerable to arbitrary command injection in conf.c in the download_with_xfercommand() function. This can be exploited when unsigned databases are used. To exploit the vulnerability, the user must enable a non-default XferCommand and retrieve an attacker-controlled crafted database and package.

Record
GHSA-f94h-gmg7-c6gw
Weakness
CWE-78
Updated
2026-11-02
OSVALPINE-CVE-2019-18182 9.8

pacman before 5.2 is vulnerable to arbitrary command injection in conf.c in the download_with_xfercommand() function. This can be exploited when unsigned databases are used. To exploit the vulnerability, the user must enable a non-default XferCommand and retrieve an attacker-controlled crafted database and package.

Record
ALPINE-CVE-2019-18182
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pacman
Alpine:v3.11
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.12
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.13
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.14
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.15
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.16
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.17
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.18
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.19
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.20
before 5.2.0-r0
5.2.0-r0
Show 4 moreShow less
Affected packages
PackageAffectedFixed
pacman
Alpine:v3.21
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.22
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.23
before 5.2.0-r0
5.2.0-r0
pacman
Alpine:v3.24
before 5.2.0-r0
5.2.0-r0

History

History
RecordedChangedSources
affected, aliases, facts, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-18182 is a critical vulnerability (CVSS 9.8) in Pacman Project Pacman, published February 24, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.67%, the 89th percentile. Fixed in pacman 5.2.0-r0.

References

Show 6 moreShow less
MoveEnter Open