CVE-2014-4657
Ansible Remote Code Execution
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
- Record
CVE-2014-4657- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
- Record
CVE-2014-4657- Updated
- 2026-11-02
EUVDEUVD-2020-0010 No score
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
- Record
EUVD-2020-0010- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qg47-5px9-32g7
9.3
Ansible Remote Code Execution
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
- Record
GHSA-qg47-5px9-32g7- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
9.8
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
- Record
CVE-2014-4657- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2014-4657
9.8
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
- Record
DEBIAN-CVE-2014-4657- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-qg47-5px9-32g7
9.3
Ansible Remote Code Execution
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
- Record
GHSA-qg47-5px9-32g7- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVPYSEC-2020-199 No score
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
- Record
PYSEC-2020-199- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ansiblePyPI |
before 1.5.4 | 1.5.4 |
ansibleDebian:12 |
before 1.5.5+dfsg-1 | 1.5.5+dfsg-1 |
ansibleDebian:13 |
before 1.5.5+dfsg-1 | 1.5.5+dfsg-1 |
ansibleDebian:14 |
before 1.5.5+dfsg-1 | 1.5.5+dfsg-1 |
ansiblePyPI |
before 1.5.4, plus listed versions 1.01.11.21.2.11.2.2 Show 16 moreShow less1.2.31.3.01.3.11.3.21.3.31.3.41.41.4.11.4.21.4.31.4.41.4.51.51.5.11.5.21.5.3 |
1.5.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-4657 is a critical vulnerability (CVSS 9.8) in Redhat Ansible, published February 20, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.43%, the 91st percentile. Fixed in ansible 1.5.4.
References
github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md
securityfocus.com/bid/68232
nvd.nist.gov/vuln/detail/CVE-2014-4657
github.com/ansible/ansible/commit/998793fd0ab55705d57527a38cee5e83f535974c
web.archive.org/web/20210120133852/https://www.securityfocus.com/bid/68232
github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-199.yaml
github.com/advisories/GHSA-qg47-5px9-32g7
security-tracker.debian.org/tracker/CVE-2014-4657
github.com/ansible/ansible