CVE-2014-3488
Denial of service in Netty
The SslHandler in Netty before 3.9.2 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted SSLv2Hello message.
Exploit likelihood
What each source reports
NVD Score used
5.0
The SslHandler in Netty before 3.9.2 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted SSLv2Hello message.
- Record
CVE-2014-3488- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
The SslHandler in Netty before 3.9.2 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted SSLv2Hello message.
- Record
CVE-2014-3488- Updated
- 2026-11-02
EUVDEUVD-2020-0475 No score
The SslHandler in Netty before 3.9.2 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted SSLv2Hello message.
- Record
EUVD-2020-0475- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9959-6p3m-wxpc No score
Denial of service in Netty
The SslHandler in Netty before 3.9.2 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted SSLv2Hello message.
- Record
GHSA-9959-6p3m-wxpc- Weakness
- CWE-119
- Updated
- 2026-11-02
OSVGHSA-9959-6p3m-wxpc No score
Denial of service in Netty
The SslHandler in Netty before 3.9.2 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted SSLv2Hello message.
- Record
GHSA-9959-6p3m-wxpc- Weakness
- CWE-119
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
io.netty:netty-handlerMaven |
before 3.9.2 | 3.9.2 |
netty-3.9Debian:8 From an advisory covering 6 CVEs |
before 3.9.0.Final-1+deb8u1, plus listed versions 3.9.0.Final-1 |
3.9.0.Final-1+deb8u1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-3488 is a medium vulnerability (CVSS 5.0) in Netty, published July 31, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.22%, the 91st percentile. Fixed in io.netty:netty-handler 3.9.2.
References
netty.io/news/2014/06/11/3-9-2-Final.html
github.com/netty/netty/issues/2562
secunia.com/advisories/59196
github.com/netty/netty/commit/2fa9400a59d0563a66908aba55c41e7285a04994
lists.debian.org/debian-lts-announce/2020/02/msg00018.html
nvd.nist.gov/vuln/detail/CVE-2014-3488
snyk.io/vuln/SNYK-JAVA-ORGJBOSSNETTY-31630
github.com/advisories/GHSA-9959-6p3m-wxpc
github.com/netty/netty