Every CVE Search/ Get API key

CVE-2020-1956

Command Injection in Kylin

8.8 HighIn KEVPublic exploitFix available

Apache Kylin 2.3.0, and releases up to 2.6.5 and 3.0.1 has some restful apis which will concatenate os command with the user input string, a user is likely to be able to execute any os command without any protection or validation.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

97.4%Up 92.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Apache Kylin 2.3.0, and releases up to 2.6.5 and 3.0.1 has some restful apis which will concatenate os command with the user input string, a user is likely to be able to execute any os command without any protection or validation.

Record
CVE-2020-1956
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
9.0 HighAV:N/AC:L/Au:S/C:C/I:C/A:C
Weakness
CWE-78
Updated
2026-11-02
CVE List 8.8

Apache Kylin 2.3.0, and releases up to 2.6.5 and 3.0.1 has some restful apis which will concatenate os command with the user input string, a user is likely to be able to execute any os command without any protection or validation.

Record
CVE-2020-1956
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
EUVDEUVD-2020-0557 8.8

Apache Kylin 2.3.0, and releases up to 2.6.5 and 3.0.1 has some restful apis which will concatenate os command with the user input string, a user is likely to be able to execute any os command without any protection or validation.

Record
EUVD-2020-0557
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-gprm-xqrc-c2j3 8.8

Command Injection in Kylin

Kylin has some restful apis which will concatenate os command with the user input string, a user is likely to be able to execute any os command without any protection or validation.

Record
GHSA-gprm-xqrc-c2j3
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:H
Weakness
CWE-78
Updated
2026-11-02
CISA KEV No score

Apache Kylin OS Command Injection Vulnerability

Apache Kylin contains an OS command injection vulnerability which could permit an attacker to perform remote code execution.

Record
CVE-2020-1956
Weakness
CWE-78
Updated
2026-11-02
OSV 8.8

Apache Kylin 2.3.0, and releases up to 2.6.5 and 3.0.1 has some restful apis which will concatenate os command with the user input string, a user is likely to be able to execute any os command without any protection or validation.

Record
CVE-2020-1956
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-gprm-xqrc-c2j3 8.8

Command Injection in Kylin

Kylin has some restful apis which will concatenate os command with the user input string, a user is likely to be able to execute any os command without any protection or validation.

Record
GHSA-gprm-xqrc-c2j3
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:H
Weakness
CWE-78
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.kylin:kylin-core-common
Maven
before 2.6.6
2.6.6
org.apache.kylin:kylin-core-common
Maven
3.0.0 up to 3.0.2
3.0.2
org.apache.kylin:kylin-core-common
Maven
before 2.6.6, plus listed versions
1.5.01.5.11.5.21.5.2.11.5.3
Show 20 moreShow less
1.5.41.5.4.11.6.02.0.02.1.02.2.02.3.02.3.12.3.22.4.02.4.12.5.02.5.12.5.22.6.02.6.12.6.22.6.32.6.42.6.5
2.6.6
org.apache.kylin:kylin-core-common
Maven
3.0.0 up to 3.0.2, plus listed versions
3.0.1
3.0.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubb510/CVE-2020-19562021-07-08
NucleiApache Kylin 3.0.1 - Command Injection Vulnerability

History

History
RecordedChangedSources
exploitation, exploits
first indexedCVE List, EUVD, GitHub Advisories, CISA KEV, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-1956 is a high vulnerability (CVSS 8.8) in Apache Kylin, published May 22, 2020. CISA lists it as known to be exploited, since March 25, 2022. EUVD reports exploitation since March 25, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 97.4%, the 99th percentile. Fixed in org.apache.kylin:kylin-core-common 2.6.6.

References

Show 13 moreShow less
MoveEnter Open