CVE-2020-12265
Path Traversal in decompress
The decompress package before 4.2.1 for Node.js is vulnerable to Arbitrary File Write via ../ in an archive member, when a symlink is used, because of Directory Traversal.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The decompress package before 4.2.1 for Node.js is vulnerable to Arbitrary File Write via ../ in an archive member, when a symlink is used, because of Directory Traversal.
- Record
CVE-2020-12265- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-22, CWE-59
- Updated
- 2026-11-02
CVE List No score
The decompress package before 4.2.1 for Node.js is vulnerable to Arbitrary File Write via ../ in an archive member, when a symlink is used, because of Directory Traversal.
- Record
CVE-2020-12265- Updated
- 2026-11-02
EUVDEUVD-2020-1238 No score
The decompress package before 4.2.1 for Node.js is vulnerable to Arbitrary File Write via ../ in an archive member, when a symlink is used, because of Directory Traversal.
- Record
EUVD-2020-1238- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qgfr-5hqp-vrw9
9.8
Path Traversal in decompress
Versions of decompress prior to 4.2.1 are vulnerable to Arbitrary File Write. The package fails to prevent extraction of files with relative paths, allowing attackers to write to any folder in the system by including filenames containing../.
Recommendation
Upgrade to version 4.2.1 or later.
- Record
GHSA-qgfr-5hqp-vrw9- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-59
- Updated
- 2026-11-02
OSV
9.8
The decompress package before 4.2.1 for Node.js is vulnerable to Arbitrary File Write via ../ in an archive member, when a symlink is used, because of Directory Traversal.
- Record
CVE-2020-12265- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-qgfr-5hqp-vrw9
9.8
Path Traversal in decompress
Versions of decompress prior to 4.2.1 are vulnerable to Arbitrary File Write. The package fails to prevent extraction of files with relative paths, allowing attackers to write to any folder in the system by including filenames containing../.
Recommendation
Upgrade to version 4.2.1 or later.
- Record
GHSA-qgfr-5hqp-vrw9- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-22, CWE-59
- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2020-12265 No score
CVE-2020-12265 in decompress - Patched by Root
Root has patched CVE-2020-12265 in the decompress package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2020-12265- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
decompressnpm |
before 4.2.1 | 4.2.1 |
decompressRoot:npm |
before 4.2.1-aikido.1 | 4.2.1-aikido.14.2.1-aikido.2 |
@rootio/decompressRoot:npm |
before 4.2.1-root.io.1 | 4.2.1-root.io.14.2.1-root.io.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2020-12265 is a critical vulnerability (CVSS 9.8) in Decompress Project Decompress, published April 26, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.12%, the 81st percentile. Fixed in decompress 4.2.1.