CVE-2017-16009
XSS via Angular Expression in ag-grid
ag-grid is an advanced data grid that is library agnostic. ag-grid is vulnerable to Cross-site Scripting (XSS) via Angular Expressions, if AngularJS is used in combination with ag-grid.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
ag-grid is an advanced data grid that is library agnostic. ag-grid is vulnerable to Cross-site Scripting (XSS) via Angular Expressions, if AngularJS is used in combination with ag-grid.
- Record
CVE-2017-16009- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
ag-grid is an advanced data grid that is library agnostic. ag-grid is vulnerable to Cross-site Scripting (XSS) via Angular Expressions, if AngularJS is used in combination with ag-grid.
- Record
CVE-2017-16009- Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2020-1346 No score
ag-grid is an advanced data grid that is library agnostic. ag-grid is vulnerable to Cross-site Scripting (XSS) via Angular Expressions, if AngularJS is used in combination with ag-grid.
- Record
EUVD-2020-1346- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-wfw3-rgfr-6g67
6.1
XSS via Angular Expression in ag-grid
Affected versions of ag-grid are vulnerable to Cross-site Scripting (XSS) via Angular Expressions, if used in combination with AngularJS.
Recommendation
Avoid using ag-grid in combination with AngularJS until a fix is available.
- Record
GHSA-wfw3-rgfr-6g67- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
ag-grid is an advanced data grid that is library agnostic. ag-grid is vulnerable to Cross-site Scripting (XSS) via Angular Expressions, if AngularJS is used in combination with ag-grid.
- Record
CVE-2017-16009- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-wfw3-rgfr-6g67
6.1
XSS via Angular Expression in ag-grid
Affected versions of ag-grid are vulnerable to Cross-site Scripting (XSS) via Angular Expressions, if used in combination with AngularJS.
Recommendation
Avoid using ag-grid in combination with AngularJS until a fix is available.
- Record
GHSA-wfw3-rgfr-6g67- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Show 7 moreShow less
OSVCLSA-2026-1780361414 No score
TuxCare security update for 2 packages (1 CVE)
TuxCare rebuilt 2 packages to address 1 CVE. Fixed in 16.0.1-tuxcare.1.
- Record
CLSA-2026-1780361414- Updated
- 2026-11-02
OSVCLSA-2026-1780361415 No score
TuxCare security update for ag-grid (1 CVE)
TuxCare rebuilt ag-grid to address 1 CVE. Fixed in 17.1.0-tuxcare.1.
- Record
CLSA-2026-1780361415- Updated
- 2026-11-02
OSVCLSA-2026-1780361416 No score
TuxCare security update for 2 packages (1 CVE)
TuxCare rebuilt 2 packages to address 1 CVE. Fixed in 17.1.1-tuxcare.1.
- Record
CLSA-2026-1780361416- Updated
- 2026-11-02
OSVCLSA-2026-1780361417 No score
TuxCare security update for 2 packages (1 CVE)
TuxCare rebuilt 2 packages to address 1 CVE. Fixed in 18.0.1-tuxcare.1.
- Record
CLSA-2026-1780361417- Updated
- 2026-11-02
OSVCLSA-2026-1781830548 No score
TuxCare security update for 2 packages (1 CVE)
TuxCare rebuilt 2 packages to address 1 CVE. Fixed in 18.0.1-tuxcare.1.
- Record
CLSA-2026-1781830548- Updated
- 2026-11-02
OSVCLSA-2026-1781830549 No score
TuxCare security update for 2 packages (1 CVE)
TuxCare rebuilt 2 packages to address 1 CVE. Fixed in 16.0.1-tuxcare.1.
- Record
CLSA-2026-1781830549- Updated
- 2026-11-02
OSVCLSA-2026-1781830550 No score
TuxCare security update for 2 packages (1 CVE)
TuxCare rebuilt 2 packages to address 1 CVE. Fixed in 17.1.1-tuxcare.1.
- Record
CLSA-2026-1781830550- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ag-gridnpm |
through 18.1.3-beta.1 | None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-16009 is a medium vulnerability (CVSS 6.1) in Ag-grid, published June 4, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.03%, the 63rd percentile. No source names a fixed version.