Every CVE Search/ Get API key

CVE-2020-25969

gnuplot v5.5 was discovered to contain a buffer overflow via the function plotrequest().

9.8 CriticalFix available

gnuplot v5.5 was discovered to contain a buffer overflow via the function plotrequest().

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.02%Up 1.0 points since Jul 6, 2023
90%50%10%1%

What each source reports

NVD Score used 9.8

gnuplot v5.5 was discovered to contain a buffer overflow via the function plotrequest().

Record
CVE-2020-25969
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-120
Updated
2026-11-02
CVE List No score

gnuplot v5.5 was discovered to contain a buffer overflow via the function plotrequest().

Record
CVE-2020-25969
Updated
2026-11-02
EUVDEUVD-2020-18599 No score

gnuplot v5.5 was discovered to contain a buffer overflow via the function plotrequest().

Record
EUVD-2020-18599
Updated
2026-11-03
GitHub AdvisoriesGHSA-8536-57cw-wqg3 9.8

gnuplot v5.5 was discovered to contain a buffer overflow via the function plotrequest().

gnuplot v5.5 was discovered to contain a buffer overflow via the function plotrequest().

Record
GHSA-8536-57cw-wqg3
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-120
Updated
2026-11-02
OSV 9.8

gnuplot v5.5 was discovered to contain a buffer overflow via the function plotrequest().

Record
CVE-2020-25969
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-25969 9.8

gnuplot v5.5 was discovered to contain a buffer overflow via the function plotrequest().

Record
DEBIAN-CVE-2020-25969
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVOESA-2023-1432 9.8

gnuplot security update

Gnuplot is a portable command-line driven graphing utility for Linux, OS/2, MS Windows, OSX, VMS, and many other platforms. The source code is copyrighted but freely distributed (i.e., you don't have to pay for it). It was originally created to allow scientists and students to visualize mathematical functions and data interactively, but has grown to support many non-interactive uses such as web scripting. It is also used as a plotting engine by third-party applications like Octave. Gnuplot has been supported and under active development since 1986.

Security Fix(es):

gnuplot v5.5 was discovered to contain a buffer overflow via the function plotrequest().(CVE-2020-25969)

Record
OESA-2023-1432
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-25969 9.8

gnuplot v5.5 was discovered to contain a buffer overflow via the function plotrequest().

Record
UBUNTU-CVE-2020-25969
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVSUSE-SU-2023:3091-1 No score

Security update for gnuplot

This update for gnuplot fixes the following issues:

  • CVE-2020-25969: Fixed buffer overflow via the function plotrequest() (bsc#1213068).
  • CVE-2020-25559: Fixed double free when executing print_set_output (bsc#1176689).
Record
SUSE-SU-2023:3091-1
Updated
2026-11-02
OSVUSN-7589-1 No score

gnuplot vulnerabilities

Tim Blazytko, Cornelius Aschermann, Sergej Schumilo, and Nils Bars discovered that Gnuplot had several memory-related issues. An attacker could possibly use these issues to cause Gnuplot to experience a buffer overflow, resulting in a denial of service or arbitrary code execution. These issues only affected Ubuntu 14.04 LTS and Ubuntu 18.04 LTS. (CVE-2018-19490, CVE-2018-19491, CVE-2018-19492)

It was discovered that Gnuplot could write out-of-bounds due to the use of strncpy(). An attacker could possibly use this issue to enable the execution of arbitrary code. This issue only affected Ubuntu 20.04 LTS. (CVE-2020-25412)

It was discovered that Gnuplot incorrectly freed memory when executing print_set_output(). An attacker could possibly use this issue to enable the execution of arbitrary code. (CVE-2020-25559)

It was discovered that Gnuplot's plotrequest() function contained a buffer overflow. An attacker could possibly use this issue to cause Gnuplot to crash, resulting in a denial of service or arbitrary code execution. (CVE-2020-25969)

It was discovered that Gnuplot's boundary3d() function could be made to divide by zero. An attacker could possibly use this issue to cause Gnuplot to crash, resulting in a denial of service. (CVE-2021-44917)

Record
USN-7589-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gnuplot
Debian:12
All versions, plus listed versions
5.4.4+dfsg1-26.0.0+dfsg1-16.0.0+dfsg1-26.0.0+dfsg1-36.0.2+dfsg1-1
Show 4 moreShow less
6.0.2+dfsg1-26.0.3+dfsg1-16.0.3+dfsg1-1~exp16.0.3+dfsg1-1~exp2
None known
gnuplot
Debian:13
before 6.0.0+dfsg1-1
6.0.0+dfsg1-1
gnuplot
Debian:14
before 6.0.0+dfsg1-1
6.0.0+dfsg1-1
gnuplot
openEuler:20.03-LTS-SP1
before 5.0.6-13.oe1
5.0.6-13.oe1
gnuplot
openEuler:20.03-LTS-SP3
before 5.0.6-13.oe1
5.0.6-13.oe1
gnuplot
openEuler:22.03-LTS
before 5.0.6-14.oe2203sp2
5.0.6-14.oe2203sp2
gnuplot
openEuler:22.03-LTS-SP1
before 5.0.6-14.oe2203sp1
5.0.6-14.oe2203sp1
gnuplot
openEuler:22.03-LTS-SP2
before 5.0.6-14.oe2203sp2
5.0.6-14.oe2203sp2
gnuplot
SUSE:Linux Enterprise Server 12 SP5
before 4.6.5-3.6.1
4.6.5-3.6.1
gnuplot
SUSE:Linux Enterprise Server for SAP Applications 12 SP5
before 4.6.5-3.6.1
4.6.5-3.6.1
Show 8 moreShow less
Affected packages
PackageAffectedFixed
gnuplot
Ubuntu:Pro:14.04:LTS
before 4.6.4-2ubuntu0.1~esm1, plus listed versions
4.6.3-24.6.4-14.6.4-2
4.6.4-2ubuntu0.1~esm1
gnuplot
Ubuntu:Pro:16.04:LTS
before 4.6.6-3ubuntu0.1+esm1, plus listed versions
4.6.6-24.6.6-34.6.6-3ubuntu0.1
4.6.6-3ubuntu0.1+esm1
gnuplot
Ubuntu:Pro:18.04:LTS
before 5.2.2+dfsg1-2ubuntu1+esm1, plus listed versions
5.0.7+dfsg1-15.2.2+dfsg1-25.2.2+dfsg1-2ubuntu1
5.2.2+dfsg1-2ubuntu1+esm1
gnuplot
Ubuntu:Pro:20.04:LTS
before 5.2.8+dfsg1-2ubuntu0.1~esm1, plus listed versions
5.2.6+dfsg1-25.2.7+dfsg1-65.2.8+dfsg1-15.2.8+dfsg1-2
5.2.8+dfsg1-2ubuntu0.1~esm1
gnuplot
Ubuntu:Pro:14.04:LTS
From an advisory covering 7 CVEs
before 4.6.4-2ubuntu0.1~esm1, plus listed versions
4.6.3-24.6.4-14.6.4-2
4.6.4-2ubuntu0.1~esm1
gnuplot
Ubuntu:Pro:16.04:LTS
From an advisory covering 7 CVEs
before 4.6.6-3ubuntu0.1+esm1, plus listed versions
4.6.6-24.6.6-34.6.6-3ubuntu0.1
4.6.6-3ubuntu0.1+esm1
gnuplot
Ubuntu:Pro:18.04:LTS
From an advisory covering 7 CVEs
before 5.2.2+dfsg1-2ubuntu1+esm1, plus listed versions
5.0.7+dfsg1-15.2.2+dfsg1-25.2.2+dfsg1-2ubuntu1
5.2.2+dfsg1-2ubuntu1+esm1
gnuplot
Ubuntu:Pro:20.04:LTS
From an advisory covering 7 CVEs
before 5.2.8+dfsg1-2ubuntu0.1~esm1, plus listed versions
5.2.6+dfsg1-25.2.7+dfsg1-65.2.8+dfsg1-15.2.8+dfsg1-2
5.2.8+dfsg1-2ubuntu0.1~esm1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-25969 is a critical vulnerability (CVSS 9.8) in Gnuplot, published July 5, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.02%, the 63rd percentile. Fixed in gnuplot 6.0.0+dfsg1-1.

References

Show 12 moreShow less
MoveEnter Open