Every CVE Search/ Get API key

CVE-2020-36427

GNOME gThumb before 3.10.1 allows an application crash via a malformed JPEG image.

5.5 MediumFix available

GNOME gThumb before 3.10.1 allows an application crash via a malformed JPEG image.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.71%Up 0.1 points since Jul 20, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

GNOME gThumb before 3.10.1 allows an application crash via a malformed JPEG image.

Record
CVE-2020-36427
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

GNOME gThumb before 3.10.1 allows an application crash via a malformed JPEG image.

Record
CVE-2020-36427
Updated
2026-11-02
EUVDEUVD-2020-23955 No score

GNOME gThumb before 3.10.1 allows an application crash via a malformed JPEG image.

Record
EUVD-2020-23955
Updated
2026-11-03
GitHub AdvisoriesGHSA-vx5q-6vmv-w8gj No score

GNOME gThumb before 3.10.1 allows an application crash via a malformed JPEG image.

GNOME gThumb before 3.10.1 allows an application crash via a malformed JPEG image.

Record
GHSA-vx5q-6vmv-w8gj
Updated
2026-11-02
OSV 5.5

GNOME gThumb before 3.10.1 allows an application crash via a malformed JPEG image.

Record
CVE-2020-36427
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-36427 5.5

GNOME gThumb before 3.10.1 allows an application crash via a malformed JPEG image.

Record
DEBIAN-CVE-2020-36427
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-36427 5.5

GNOME gThumb before 3.10.1 allows an application crash via a malformed JPEG image.

Record
UBUNTU-CVE-2020-36427
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-5680-1 No score

gThumb vulnerabilities

It was discovered that gThumb did not properly managed memory when processing certain image files. If a user were tricked into opening a specially crafted JPEG file, an attacker could possibly use this issue to cause gThumb to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2019-20326)

It was discovered that gThumb did not properly handled certain malformed image files. If a user were tricked into opening a specially crafted JPEG file, an attacker could possibly use this issue to cause gThumb to crash, resulting in a denial of service. (CVE-2020-36427)

Record
USN-5680-1
Updated
2026-11-02
OSVUSN-5681-1 No score

gThumb vulnerabilities

It was discovered that gThumb did not properly managed memory under certain circumstances. An attacker could possibly use this issue to cause gThumb to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2018-18718)

It was discovered that gThumb did not properly managed memory when processing certain image files. If a user were tricked into opening a specially crafted JPEG file, an attacker could possibly use this issue to cause gThumb to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2019-20326)

It was discovered that gThumb did not properly handled certain malformed image files. If a user were tricked into opening a specially crafted JPEG file, an attacker could possibly use this issue to cause gThumb to crash, resulting in a denial of service. (CVE-2020-36427)

Record
USN-5681-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gthumb
Debian:12
before 3:3.11.1-0.1
3:3.11.1-0.1
gthumb
Debian:13
before 3:3.11.1-0.1
3:3.11.1-0.1
gthumb
Debian:14
before 3:3.11.1-0.1
3:3.11.1-0.1
gthumb
Ubuntu:Pro:16.04:LTS
before 3:3.4.3-1ubuntu0.1~esm1, plus listed versions
3:3.3.1.is.3.2.8-0ubuntu33:3.4.1-23:3.4.1-33:3.4.1-43:3.4.3-1
3:3.4.3-1ubuntu0.1~esm1
gthumb
Ubuntu:Pro:18.04:LTS
before 3:3.6.1-1ubuntu0.1~esm1, plus listed versions
3:3.5.2-2ubuntu13:3.5.3-13:3.5.4-13:3.6.0-13:3.6.0-23:3.6.0-33:3.6.0-43:3.6.1-1
3:3.6.1-1ubuntu0.1~esm1
gthumb
Ubuntu:20.04:LTS
before 3:3.8.0-2.1ubuntu0.1, plus listed versions
3:3.8.0-23:3.8.0-2.13:3.8.0-2.1build1
3:3.8.0-2.1ubuntu0.1
gthumb
Ubuntu:20.04:LTS
From an advisory covering 2 CVEs
before 3:3.8.0-2.1ubuntu0.1, plus listed versions
3:3.8.0-23:3.8.0-2.13:3.8.0-2.1build1
3:3.8.0-2.1ubuntu0.1
gthumb
Ubuntu:Pro:16.04:LTS
From an advisory covering 3 CVEs
before 3:3.4.3-1ubuntu0.1~esm1, plus listed versions
3:3.3.1.is.3.2.8-0ubuntu33:3.4.1-23:3.4.1-33:3.4.1-43:3.4.3-1
3:3.4.3-1ubuntu0.1~esm1
gthumb
Ubuntu:Pro:18.04:LTS
From an advisory covering 3 CVEs
before 3:3.6.1-1ubuntu0.1~esm1, plus listed versions
3:3.5.2-2ubuntu13:3.5.3-13:3.5.4-13:3.6.0-13:3.6.0-23:3.6.0-33:3.6.0-43:3.6.1-1
3:3.6.1-1ubuntu0.1~esm1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-36427 is a medium vulnerability (CVSS 5.5) in Gnome Gthumb, published July 19, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.71%, the 53rd percentile. Fixed in gthumb 3:3.11.1-0.1.

References

Show 5 moreShow less
MoveEnter Open