Every CVE Search/ Get API key

CVE-2020-3811

qmail-verify as used in netqmail 1.06 is prone to a mail-address verification bypass vulnerability.

7.5 HighFix available

qmail-verify as used in netqmail 1.06 is prone to a mail-address verification bypass vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.81%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

qmail-verify as used in netqmail 1.06 is prone to a mail-address verification bypass vulnerability.

Record
CVE-2020-3811
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-665, CWE-863
Updated
2026-11-02
CVE List No score

qmail-verify as used in netqmail 1.06 is prone to a mail-address verification bypass vulnerability.

Record
CVE-2020-3811
Updated
2026-11-02
EUVDEUVD-2020-25076 No score

qmail-verify as used in netqmail 1.06 is prone to a mail-address verification bypass vulnerability.

Record
EUVD-2020-25076
Updated
2026-11-03
GitHub AdvisoriesGHSA-w7qp-9896-2fvp 7.5

qmail-verify as used in netqmail 1.06 is prone to a mail-address verification bypass vulnerability.

qmail-verify as used in netqmail 1.06 is prone to a mail-address verification bypass vulnerability.

Record
GHSA-w7qp-9896-2fvp
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-20, CWE-665
Updated
2026-11-02
OSVUBUNTU-CVE-2020-3811 7.5

qmail-verify as used in netqmail 1.06 is prone to a mail-address verification bypass vulnerability.

Record
UBUNTU-CVE-2020-3811
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVUSN-4556-1 No score

netqmail vulnerabilities

It was discovered that netqmail did not properly handle certain input. Both remote and local attackers could use this vulnerability to cause netqmail to crash or execute arbitrary code. (CVE-2005-1513, CVE-2005-1514, CVE-2005-1515)

It was discovered that netqmail did not properly handle certain input when validating email addresses. An attacker could use this to bypass email address validation. (CVE-2020-3811)

It was discovered that netqmail did not properly handle certain input when validating email addresses. An attacker could use this vulnerability to cause netqmail to disclose sensitive information. (CVE-2020-3812)

Record
USN-4556-1
Updated
2026-11-02
OSVUSN-4621-1 No score

netqmail vulnerabilities

It was discovered that netqmail did not properly handle certain input. Both remote and local attackers could use this vulnerability to cause netqmail to crash or execute arbitrary code. (CVE-2005-1513, CVE-2005-1514, CVE-2005-1515)

It was discovered that netqmail did not properly handle certain input when validating email addresses. An attacker could use this to bypass email address validation. (CVE-2020-3811)

It was discovered that netqmail did not properly handle certain input when validating email addresses. An attacker could use this vulnerability to cause netqmail to disclose sensitive information. (CVE-2020-3812)

Record
USN-4621-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
netqmail
Debian:8
From an advisory covering 5 CVEs
before 1.06-6.2~deb8u1, plus listed versions
1.06-51.06-61.06-6.1
1.06-6.2~deb8u1
netqmail
Debian:9
From an advisory covering 5 CVEs
before 1.06-6.2~deb9u1, plus listed versions
1.06-61.06-6.11.06-6.2~deb8u1
1.06-6.2~deb9u1
netqmail
Debian:10
From an advisory covering 5 CVEs
before 1.06-6.2~deb10u1, plus listed versions
1.06-61.06-6.11.06-6.2~deb8u11.06-6.2~deb9u1
1.06-6.2~deb10u1
netqmail
Ubuntu:Pro:14.04:LTS
before 1.06-6.2~deb10u1build0.14.04.1+esm1, plus listed versions
1.06-5
1.06-6.2~deb10u1build0.14.04.1+esm1
netqmail
Ubuntu:16.04:LTS
before 1.06-6.2~deb10u1build0.16.04.1, plus listed versions
1.06-5
1.06-6.2~deb10u1build0.16.04.1
netqmail
Ubuntu:18.04:LTS
before 1.06-6.2~deb10u1build0.18.04.1, plus listed versions
1.06-6
1.06-6.2~deb10u1build0.18.04.1
netqmail
Ubuntu:20.04:LTS
before 1.06-6.2~deb10u1build0.20.04.1, plus listed versions
1.06-6.1
1.06-6.2~deb10u1build0.20.04.1
netqmail
Ubuntu:20.04:LTS
From an advisory covering 5 CVEs
before 1.06-6.2~deb10u1build0.20.04.1, plus listed versions
1.06-6.1
1.06-6.2~deb10u1build0.20.04.1
netqmail
Ubuntu:16.04:LTS
From an advisory covering 5 CVEs
before 1.06-6.2~deb10u1build0.16.04.1, plus listed versions
1.06-5
1.06-6.2~deb10u1build0.16.04.1
netqmail
Ubuntu:18.04:LTS
From an advisory covering 5 CVEs
before 1.06-6.2~deb10u1build0.18.04.1, plus listed versions
1.06-6
1.06-6.2~deb10u1build0.18.04.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-3811 is a high vulnerability (CVSS 7.5) in Debian Netqmail, published May 24, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.81%, the 78th percentile. Fixed in netqmail 1.06-6.2~deb10u1build0.14.04.1+esm1.

References

Show 9 moreShow less
MoveEnter Open