Every CVE Search/ Get API key

CVE-2020-6061

An exploitable heap overflow vulnerability exists in the way CoTURN 4.5.1.1 web server parses...

7.0 HighFix available

An exploitable heap out-of-bounds read vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to information leaks and other misbehavior. An attacker needs to send an HTTPS request to trigger this vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
High

Exploit likelihood

5.12%Up 3.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.0

An exploitable heap out-of-bounds read vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to information leaks and other misbehavior. An attacker needs to send an HTTPS request to trigger this vulnerability.

Record
CVE-2020-6061
CVSS 3.0
7.0 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
Updated
2026-11-02
EUVDEUVD-2020-27215 7.0

An exploitable heap out-of-bounds read vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to information leaks and other misbehavior. An attacker needs to send an HTTPS request to trigger this vulnerability.

Record
EUVD-2020-27215
CVSS 3.0
7.0 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-9vj8-fr5m-q39w 9.8

An exploitable heap overflow vulnerability exists in the way CoTURN 4.5.1.1 web server parses...

An exploitable heap overflow vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to information leaks and other misbehavior. An attacker needs to send an HTTPS request to trigger this vulnerability.

Record
GHSA-9vj8-fr5m-q39w
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-125, CWE-787
Updated
2026-11-02
NVD 9.8

An exploitable heap out-of-bounds read vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to information leaks and other misbehavior. An attacker needs to send an HTTPS request to trigger this vulnerability.

Record
CVE-2020-6061
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
7.0 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-125
Updated
2026-11-02
OSV 9.8

An exploitable heap out-of-bounds read vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to information leaks and other misbehavior. An attacker needs to send an HTTPS request to trigger this vulnerability.

Record
CVE-2020-6061
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-6061 9.8

An exploitable heap out-of-bounds read vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to information leaks and other misbehavior. An attacker needs to send an HTTPS request to trigger this vulnerability.

Record
DEBIAN-CVE-2020-6061
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2020-6061 9.8

An exploitable heap out-of-bounds read vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to information leaks and other misbehavior. An attacker needs to send an HTTPS request to trigger this vulnerability.

Record
UBUNTU-CVE-2020-6061
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
7.0 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
Updated
2026-11-02
OSVMGASA-2020-0254 No score

Updated coturn packages fix security vulnerability

Updated the coturn package in order to fix some security vulnerabilities:

http_server.c: An exploitable heap overflow vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to information leaks and other misbehavior. An attacker needs to send an HTTPS request to trigger this vulnerability (CVE-2020-6061).

http_server.c An exploitable denial-of-service vulnerability exists in the way CoTURN 4.5.1.1 web server parses POST requests. A specially crafted HTTP POST request can lead to server crash and denial of service. An attacker needs to send an HTTP request to trigger this vulnerability (CVE-2020-6062).

Record
MGASA-2020-0254
Updated
2026-11-02
OSVopenSUSE-SU-2024:10696-1 No score

coturn-4.5.2-2.2 on GA media

These are all security issues fixed in the coturn-4.5.2-2.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10696-1
Updated
2026-11-02
OSVUSN-4415-1 No score

coturn vulnerabilities

Felix Dörre discovered that coTURN response buffer is not initialized properly. An attacker could possibly use this issue to obtain sensitive information. (CVE-2020-4067)

It was discovered that coTURN web server incorrectly handled HTTP POST requests. An attacker could possibly use this issue to cause a denial of service, obtain sensitive information or other unspecified impact. (CVE-2020-6061, CVE-2020-6062)

Record
USN-4415-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
coturn
Debian:12
before 4.5.1.1-1.2
4.5.1.1-1.2
coturn
Debian:13
before 4.5.1.1-1.2
4.5.1.1-1.2
coturn
Debian:14
before 4.5.1.1-1.2
4.5.1.1-1.2
coturn
Debian:9
From an advisory covering 3 CVEs
before 4.5.0.5-1+deb9u2, plus listed versions
4.5.0.5-14.5.0.5-1+deb9u1
4.5.0.5-1+deb9u2
coturn
Debian:10
From an advisory covering 3 CVEs
before 4.5.1.1-1.1+deb10u1, plus listed versions
4.5.1.1-1.1
4.5.1.1-1.1+deb10u1
coturn
Mageia:7
From an advisory covering 2 CVEs
before 4.5.0.7-2.3.mga7
4.5.0.7-2.3.mga7
coturn
Ubuntu:16.04:LTS
before 4.5.0.3-1ubuntu0.3, plus listed versions
4.4.5.4-24.5.0.2-34.5.0.3-14.5.0.3-1build14.5.0.3-1ubuntu0.2
4.5.0.3-1ubuntu0.3
coturn
Ubuntu:18.04:LTS
before 4.5.0.7-1ubuntu2.18.04.2, plus listed versions
4.5.0.6-1ubuntu24.5.0.7-1ubuntu14.5.0.7-1ubuntu24.5.0.7-1ubuntu2.18.04.1
4.5.0.7-1ubuntu2.18.04.2
coturn
Ubuntu:20.04:LTS
before 4.5.1.1-1.1ubuntu0.20.04.1, plus listed versions
4.5.1.1-1.1build14.5.1.1-1.1build2
4.5.1.1-1.1ubuntu0.20.04.1
coturn
Ubuntu:16.04:LTS
From an advisory covering 3 CVEs
before 4.5.0.3-1ubuntu0.3, plus listed versions
4.4.5.4-24.5.0.2-34.5.0.3-14.5.0.3-1build14.5.0.3-1ubuntu0.2
4.5.0.3-1ubuntu0.3
coturn
Ubuntu:18.04:LTS
From an advisory covering 3 CVEs
before 4.5.0.7-1ubuntu2.18.04.2, plus listed versions
4.5.0.6-1ubuntu24.5.0.7-1ubuntu14.5.0.7-1ubuntu24.5.0.7-1ubuntu2.18.04.1
4.5.0.7-1ubuntu2.18.04.2
coturn
Ubuntu:20.04:LTS
From an advisory covering 3 CVEs
before 4.5.1.1-1.1ubuntu0.20.04.1, plus listed versions
4.5.1.1-1.1build14.5.1.1-1.1build2
4.5.1.1-1.1ubuntu0.20.04.1
coturn
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 4.5.2-2.2
4.5.2-2.2

History

History
RecordedChangedSources
affected, facts
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-6061 is a high vulnerability (CVSS 7.0) in Coturn, published February 19, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.12%, the 92nd percentile. Fixed in coturn 4.5.1.1-1.2.

References

Show 18 moreShow less
MoveEnter Open