Every CVE Search/ Get API key

CVE-2021-39229

Regular expression deinal of service in apprise

7.5 HighFix available

Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is here. The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove apprise/plugins/NotifyIFTTT.py to eliminate the service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.89%Up 0.9 points since Sep 21, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.5

Regular expression deinal of service in apprise

Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is here. The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove apprise/plugins/NotifyIFTTT.py to eliminate the service.

Record
CVE-2021-39229
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
EUVDEUVD-2021-0025 7.5

Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is here. The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove apprise/plugins/NotifyIFTTT.py to eliminate the service.

Record
EUVD-2021-0025
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-qhmp-h54x-38qr 8.7

Apprise vulnerable to regex injection with IFTTT Plugin

Impact

Anyone publicly hosting the Apprise library and granting them access to the IFTTT notification service.

Patches

Update to Apprise v0.9.5.1

# Install Apprise v0.9.5.1 from PyPI
pip install apprise==0.9.5.1

The patch to the problem was performed here.

Workarounds

Alternatively, if upgrading is not an option, you can safely remove the following file:

  • apprise/plugins/NotifyIFTTT.py

The above will eliminate the ability to use IFTTT, but everything else will work smoothly.

For more information

If you have any questions or comments about this advisory:

Additional Credit

Github would not allow me to additionally credit Rasmus Petersen, but I would like to put that here at the very least - thank you for finding and reporting this issue along with those already credited

Additional Notes:

  • Github would not allow me to add/tag the 2 CWE's this issue is applicable to (only CWE-400). The other is: CWE-730 (placed in the title)
Record
GHSA-qhmp-h54x-38qr
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
NVD 7.5

Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is here. The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove apprise/plugins/NotifyIFTTT.py to eliminate the service.

Record
CVE-2021-39229
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-400
Updated
2026-11-02
OSV 7.5

Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is here. The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove apprise/plugins/NotifyIFTTT.py to eliminate the service.

Record
CVE-2021-39229
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-qhmp-h54x-38qr 8.7

Apprise vulnerable to regex injection with IFTTT Plugin

Impact

Anyone publicly hosting the Apprise library and granting them access to the IFTTT notification service.

Patches

Update to Apprise v0.9.5.1

# Install Apprise v0.9.5.1 from PyPI
pip install apprise==0.9.5.1

The patch to the problem was performed here.

Workarounds

Alternatively, if upgrading is not an option, you can safely remove the following file:

  • apprise/plugins/NotifyIFTTT.py

The above will eliminate the ability to use IFTTT, but everything else will work smoothly.

For more information

If you have any questions or comments about this advisory:

Additional Credit

Github would not allow me to additionally credit Rasmus Petersen, but I would like to put that here at the very least - thank you for finding and reporting this issue along with those already credited

Additional Notes:

  • Github would not allow me to add/tag the 2 CWE's this issue is applicable to (only CWE-400). The other is: CWE-730 (placed in the title)
Record
GHSA-qhmp-h54x-38qr
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
OSVPYSEC-2021-327 No score

Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is here. The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove apprise/plugins/NotifyIFTTT.py to eliminate the service.

Record
PYSEC-2021-327
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apprise
PyPI
through 0.9.4
0.9.5.1
apprise
PyPI
before 0.9.5.1, plus listed versions
0.0.10.0.20.0.30.0.40.0.5
Show 28 moreShow less
0.0.60.0.70.0.80.0.90.5.00.5.20.7.30.7.40.7.50.7.60.7.70.7.80.7.90.8.00.8.10.8.20.8.30.8.40.8.50.8.60.8.70.8.80.8.90.9.00.9.10.9.20.9.30.9.4
0.9.5.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-39229 is a high vulnerability (CVSS 7.5) in Caronc Apprise, published September 20, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.89%, the 79th percentile. Fixed in apprise 0.9.5.1.

References

MoveEnter Open