Every CVE Search/ Get API key

CVE-2016-11086

Improper Certificate Validation in oauth ruby gem

7.4 HighFix available

lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.86%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.4

lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.

Record
CVE-2016-11086
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:N
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.

Record
CVE-2016-11086
Updated
2026-11-02
EUVDEUVD-2021-0781 No score

lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.

Record
EUVD-2021-0781
Updated
2026-11-03
GitHub AdvisoriesGHSA-7359-3c6r-hfc2 7.4

Improper Certificate Validation in oauth ruby gem

lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.

Record
GHSA-7359-3c6r-hfc2
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-295
Updated
2026-11-02
OSV 7.4

lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.

Record
CVE-2016-11086
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2016-11086 7.4

lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.

Record
DEBIAN-CVE-2016-11086
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02
OSVGHSA-7359-3c6r-hfc2 7.4

Improper Certificate Validation in oauth ruby gem

lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.

Record
GHSA-7359-3c6r-hfc2
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-295
Updated
2026-11-02
OSVUBUNTU-CVE-2016-11086 7.4

lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.

Record
UBUNTU-CVE-2016-11086
CVSS 3.1
7.4 HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
oauth
RubyGems
before 0.5.5
0.5.5
ruby-oauth
Debian:12
All versions, plus listed versions
0.5.4-1.10.5.6-11.1.7-11.1.8-1
None known
ruby-oauth
Debian:13
All versions, plus listed versions
0.5.4-1.10.5.6-11.1.7-11.1.8-1
None known
ruby-oauth
Debian:14
All versions, plus listed versions
0.5.4-1.10.5.6-11.1.7-11.1.8-1
None known
oauth
RubyGems
before 0.5.5, plus listed versions
0.1.10.2.00.2.10.2.20.2.4
Show 23 moreShow less
0.2.60.2.70.3.00.3.10.3.20.3.30.3.40.3.50.3.60.3.7.pre10.4.00.4.10.4.20.4.30.4.40.4.50.4.60.4.70.5.00.5.10.5.20.5.30.5.4
0.5.5
ruby-oauth
Ubuntu:16.04:LTS
All versions, plus listed versions
0.4.7-3
None known
ruby-oauth
Ubuntu:18.04:LTS
All versions, plus listed versions
0.5.3-1
None known
ruby-oauth
Ubuntu:20.04:LTS
All versions, plus listed versions
0.5.4-1
None known
ruby-oauth
Ubuntu:22.04:LTS
All versions, plus listed versions
0.5.4-1.1
None known
ruby-oauth
Ubuntu:24.04:LTS
All versions, plus listed versions
0.5.4-1.1
None known
ruby-oauth
Ubuntu:25.10
All versions, plus listed versions
0.5.4-1.1
None known
ruby-oauth
Ubuntu:26.10
All versions, plus listed versions
0.5.4-1.11.1.7-11.1.8-1
None known
ruby-oauth
Ubuntu:26.04:LTS
All versions, plus listed versions
0.5.4-1.1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2016-11086 is a high vulnerability (CVSS 7.4) in Oauth-ruby Project Oauth-ruby, published September 24, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.86%, the 58th percentile. Fixed in oauth 0.5.5.

References

Show 4 moreShow less
MoveEnter Open