Every CVE Search/ Get API key

CVE-2018-11765

Improper Authentication in Apache Hadoop

7.5 HighFix available

In Apache Hadoop versions 3.0.0-alpha2 to 3.0.0, 2.9.0 to 2.9.2, 2.8.0 to 2.8.5, any users can access some servlets without authentication when Kerberos authentication is enabled and SPNEGO through HTTP is not enabled.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

5.21%Down 2.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

In Apache Hadoop versions 3.0.0-alpha2 to 3.0.0, 2.9.0 to 2.9.2, 2.8.0 to 2.8.5, any users can access some servlets without authentication when Kerberos authentication is enabled and SPNEGO through HTTP is not enabled.

Record
CVE-2018-11765
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Weakness
CWE-287
Updated
2026-11-02
CVE List No score

In Apache Hadoop versions 3.0.0-alpha2 to 3.0.0, 2.9.0 to 2.9.2, 2.8.0 to 2.8.5, any users can access some servlets without authentication when Kerberos authentication is enabled and SPNEGO through HTTP is not enabled.

Record
CVE-2018-11765
Updated
2026-11-02
EUVDEUVD-2021-0868 No score

In Apache Hadoop versions 3.0.0-alpha2 to 3.0.0, 2.9.0 to 2.9.2, 2.8.0 to 2.8.5, any users can access some servlets without authentication when Kerberos authentication is enabled and SPNEGO through HTTP is not enabled.

Record
EUVD-2021-0868
Updated
2026-11-03
GitHub AdvisoriesGHSA-rhh9-cm65-3w54 7.5

Improper Authentication in Apache Hadoop

In Apache Hadoop versions 3.0.0-alpha2 to 3.0.0, 2.9.0 to 2.9.2, 2.8.0 to 2.8.5, any users can access some servlets without authentication when Kerberos authentication is enabled and SPNEGO through HTTP is not enabled.

Record
GHSA-rhh9-cm65-3w54
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-287
Updated
2026-11-02
OSV 7.5

In Apache Hadoop versions 3.0.0-alpha2 to 3.0.0, 2.9.0 to 2.9.2, 2.8.0 to 2.8.5, any users can access some servlets without authentication when Kerberos authentication is enabled and SPNEGO through HTTP is not enabled.

Record
CVE-2018-11765
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVGHSA-rhh9-cm65-3w54 7.5

Improper Authentication in Apache Hadoop

In Apache Hadoop versions 3.0.0-alpha2 to 3.0.0, 2.9.0 to 2.9.2, 2.8.0 to 2.8.5, any users can access some servlets without authentication when Kerberos authentication is enabled and SPNEGO through HTTP is not enabled.

Record
GHSA-rhh9-cm65-3w54
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-287
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.hadoop:hadoop-main
Maven
3.0.0-alpha2 to 3.0.0
3.0.1
org.apache.hadoop:hadoop-main
Maven
2.9.0 to 2.9.2
2.9.3
org.apache.hadoop:hadoop-main
Maven
2.8.0 to 2.8.5
2.8.6
org.apache.hadoop:hadoop-main
Maven
3.0.0-alpha2 up to 3.0.1, plus listed versions
3.0.03.0.0-alpha33.0.0-alpha43.0.0-beta1
3.0.1
org.apache.hadoop:hadoop-main
Maven
2.9.0 up to 2.9.3, plus listed versions
2.9.12.9.2
2.9.3
org.apache.hadoop:hadoop-main
Maven
2.8.0 up to 2.8.6, plus listed versions
2.8.12.8.22.8.32.8.42.8.5
2.8.6

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-11765 is a high vulnerability (CVSS 7.5) in Apache Hadoop, published September 30, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.21%, the 92nd percentile. Fixed in org.apache.hadoop:hadoop-main 3.0.1.

References

Show 18 moreShow less
MoveEnter Open