CVE-2021-33604
Reflected cross-site scripting in development mode handler in Vaadin 14, 15-19
URL encoding error in development mode handler in com.vaadin:flow-server versions 2.0.0 through 2.6.1 (Vaadin 14.0.0 through 14.6.1), 3.0.0 through 6.0.9 (Vaadin 15.0.0 through 19.0.8) allows local user to execute arbitrary JavaScript code by opening crafted URL in browser.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- High
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
2.5
Reflected cross-site scripting in development mode handler in Vaadin 14, 15-19
URL encoding error in development mode handler in com.vaadin:flow-server versions 2.0.0 through 2.6.1 (Vaadin 14.0.0 through 14.6.1), 3.0.0 through 6.0.9 (Vaadin 15.0.0 through 19.0.8) allows local user to execute arbitrary JavaScript code by opening crafted URL in browser.
- Record
CVE-2021-33604- CVSS 3.1
- 2.5 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N - Weakness
- CWE-172
- Updated
- 2026-11-02
EUVDEUVD-2021-1309
2.5
URL encoding error in development mode handler in com.vaadin:flow-server versions 2.0.0 through 2.6.1 (Vaadin 14.0.0 through 14.6.1), 3.0.0 through 6.0.9 (Vaadin 15.0.0 through 19.0.8) allows local user to execute arbitrary JavaScript code by opening crafted URL in browser.
- Record
EUVD-2021-1309- CVSS 3.1
- 2.5 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c99r-67x4-whj6
2.5
Reflected cross-site scripting in development mode handler in Vaadin 14, 15-19
URL encoding error in development mode handler in com.vaadin:flow-server versions 2.0.0 through 2.6.1 (Vaadin 14.0.0 through 14.6.1), 3.0.0 through 6.0.9 (Vaadin 15.0.0 through 19.0.8) allows local user to execute arbitrary JavaScript code by opening crafted URL in browser.
- Record
GHSA-c99r-67x4-whj6- CVSS 3.1
- 2.5 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N - Weakness
- CWE-172
- Updated
- 2026-11-02
NVD
2.5
URL encoding error in development mode handler in com.vaadin:flow-server versions 2.0.0 through 2.6.1 (Vaadin 14.0.0 through 14.6.1), 3.0.0 through 6.0.9 (Vaadin 15.0.0 through 19.0.8) allows local user to execute arbitrary JavaScript code by opening crafted URL in browser.
- Record
CVE-2021-33604- CVSS 3.1
- 2.5 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N - CVSS 2.0
- 1.2 Low
AV:L/AC:H/Au:N/C:P/I:N/A:N - Weakness
- CWE-172
- Updated
- 2026-11-02
OSV
2.5
URL encoding error in development mode handler in com.vaadin:flow-server versions 2.0.0 through 2.6.1 (Vaadin 14.0.0 through 14.6.1), 3.0.0 through 6.0.9 (Vaadin 15.0.0 through 19.0.8) allows local user to execute arbitrary JavaScript code by opening crafted URL in browser.
- Record
CVE-2021-33604- CVSS 3.1
- 2.5 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N - Updated
- 2026-11-06
OSVGHSA-c99r-67x4-whj6
2.5
Reflected cross-site scripting in development mode handler in Vaadin 14, 15-19
URL encoding error in development mode handler in com.vaadin:flow-server versions 2.0.0 through 2.6.1 (Vaadin 14.0.0 through 14.6.1), 3.0.0 through 6.0.9 (Vaadin 15.0.0 through 19.0.8) allows local user to execute arbitrary JavaScript code by opening crafted URL in browser.
- Record
GHSA-c99r-67x4-whj6- CVSS 3.1
- 2.5 Low
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N - Weakness
- CWE-172
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
com.vaadin:vaadin-bomMaven |
14.0.0 to 14.6.1 | 14.6.2 |
com.vaadin:vaadin-bomMaven |
15.0.0 to 19.0.8 | 19.0.9 |
com.vaadin:vaadin-bomMaven |
14.0.0 up to 14.6.2, plus listed versions 14.0.114.0.1014.0.1114.0.1214.0.13 Show 45 moreShow less14.0.1414.0.1514.0.214.0.314.0.414.0.514.0.614.0.714.0.814.0.914.1.014.1.114.1.1614.1.1714.1.1814.1.1914.1.214.1.2014.1.2114.1.2214.1.2314.1.2414.1.2514.1.2614.1.2714.1.2814.1.314.1.414.1.514.2.014.2.114.2.214.2.314.3.014.3.114.3.214.3.314.3.414.3.514.3.614.3.714.3.814.3.914.4.014.4.1 |
14.6.2 |
com.vaadin:vaadin-bomMaven |
15.0.0 up to 19.0.9, plus listed versions 15.0.115.0.215.0.315.0.415.0.5 Show 35 moreShow less15.0.616.0.016.0.116.0.216.0.316.0.416.0.517.0.017.0.117.0.1017.0.1117.0.217.0.317.0.417.0.617.0.717.0.817.0.918.0.018.0.118.0.218.0.318.0.418.0.518.0.618.0.719.0.019.0.119.0.219.0.319.0.419.0.519.0.619.0.719.0.8 |
19.0.9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| facts | OSV | |
| aliases, products, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-33604 is a low vulnerability (CVSS 2.5) in Flow Flow-server, published June 24, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 21st percentile. Fixed in com.vaadin:vaadin-bom 14.6.2.
References
Left out here: 17 versions. The JSON record has them.