CVE-2021-35210
Cross site scripting in the system log
Contao 4.5.x through 4.9.x before 4.9.16, and 4.10.x through 4.11.x before 4.11.5, allows XSS. It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Contao 4.5.x through 4.9.x before 4.9.16, and 4.10.x through 4.11.x before 4.11.5, allows XSS. It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.
- Record
CVE-2021-35210- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Contao 4.5.x through 4.9.x before 4.9.16, and 4.10.x through 4.11.x before 4.11.5, allows XSS. It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.
- Record
CVE-2021-35210- Updated
- 2026-11-02
EUVDEUVD-2021-1472 No score
Contao 4.5.x through 4.9.x before 4.9.16, and 4.10.x through 4.11.x before 4.11.5, allows XSS. It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.
- Record
EUVD-2021-1472- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h58v-c6rf-g9f7
6.1
Cross site scripting in the system log
Impact
It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.
Patches
Update to Contao 4.9.16 or 4.11.5.
Workarounds
Disable the system log module in the back end for all users (especially admin users).
References
https://contao.org/en/security-advisories/cross-site-scripting-in-the-system-log-2021
For more information
If you have any questions or comments about this advisory, open an issue in contao/contao.
- Record
GHSA-h58v-c6rf-g9f7- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Contao 4.5.x through 4.9.x before 4.9.16, and 4.10.x through 4.11.x before 4.11.5, allows XSS. It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.
- Record
CVE-2021-35210- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-h58v-c6rf-g9f7
6.1
Cross site scripting in the system log
Impact
It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.
Patches
Update to Contao 4.9.16 or 4.11.5.
Workarounds
Disable the system log module in the back end for all users (especially admin users).
References
https://contao.org/en/security-advisories/cross-site-scripting-in-the-system-log-2021
For more information
If you have any questions or comments about this advisory, open an issue in contao/contao.
- Record
GHSA-h58v-c6rf-g9f7- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
contao/core-bundlePackagist |
4.5.0 up to 4.9.16 | 4.9.16 |
contao/core-bundlePackagist |
4.10.0 up to 4.11.5 | 4.11.5 |
contao/contaoPackagist |
4.5.0 up to 4.9.16 | 4.9.16 |
contao/contaoPackagist |
4.10.0 up to 4.11.5 | 4.11.5 |
contao/core-bundlePackagist |
4.5.0 up to 4.9.16, plus listed versions 4.5.14.5.104.5.114.5.124.5.13 Show 45 moreShow less4.5.144.5.24.5.34.5.44.5.54.5.64.5.74.5.84.5.94.6.04.6.0-RC14.6.0-RC24.6.0-RC34.6.14.6.104.6.114.6.124.6.134.6.144.6.24.6.34.6.44.6.54.6.64.6.74.6.84.6.94.7.04.7.0-RC14.7.0-RC24.7.0-RC34.7.0-RC44.7.14.7.24.7.34.7.44.7.54.7.64.7.74.8.04.8.0-RC14.8.0-RC24.8.14.8.24.8.3 |
4.9.16 |
contao/core-bundlePackagist |
4.10.0 up to 4.11.5, plus listed versions 4.10.14.10.24.10.34.10.44.10.5 Show 9 moreShow less4.10.64.10.74.11.04.11.0-RC14.11.0-RC24.11.14.11.24.11.34.11.4 |
4.11.5 |
contao/contaoPackagist |
4.5.0 up to 4.9.16, plus listed versions 4.5.134.5.144.6.04.6.14.6.10 Show 45 moreShow less4.6.114.6.124.6.134.6.144.6.24.6.34.6.44.6.54.6.64.6.74.6.84.6.94.7.04.7.0-RC14.7.0-RC24.7.0-RC34.7.0-RC44.7.14.7.24.7.34.7.44.7.54.7.64.7.74.8.04.8.0-RC14.8.0-RC24.8.14.8.24.8.34.8.44.8.54.8.64.8.74.8.84.9.04.9.0-RC14.9.0-RC24.9.14.9.104.9.114.9.124.9.134.9.144.9.15 |
4.9.16 |
contao/contaoPackagist |
4.10.0 up to 4.11.5, plus listed versions 4.10.14.10.24.10.34.10.44.10.5 Show 9 moreShow less4.10.64.10.74.11.04.11.0-RC14.11.0-RC24.11.14.11.24.11.34.11.4 |
4.11.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-35210 is a medium vulnerability (CVSS 6.1) in Contao, published June 23, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. Fixed in contao/core-bundle 4.9.16.
References
contao.org/en/security-advisories/cross-site-scripting-in-the-system-log-2021.html
github.com/contao/contao/security/advisories/GHSA-h58v-c6rf-g9f7
nvd.nist.gov/vuln/detail/CVE-2021-35210
github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2021-35210.yaml
github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2021-35210.yaml
github.com/advisories/GHSA-h58v-c6rf-g9f7
github.com/contao/contao
Left out here: 31 versions. The JSON record has them.