Every CVE Search/ Get API key

CVE-2021-28025

Integer Overflow vulnerability in qsvghandler.cpp in Qt qtsvg versions 5.15.1, 6.0.0, 6.0.2, and...

5.5 MediumFix available

Integer Overflow vulnerability in qsvghandler.cpp in Qt qtsvg versions 5.15.1, 6.0.0, 6.0.2, and 6.2, allows local attackers to cause a denial of service (DoS).

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.29%Up 0.2 points since Aug 12, 2023
90%50%10%1%

What each source reports

NVD Score used 5.5

Integer Overflow vulnerability in qsvghandler.cpp in Qt qtsvg versions 5.15.1, 6.0.0, 6.0.2, and 6.2, allows local attackers to cause a denial of service (DoS).

Record
CVE-2021-28025
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
CVE List No score

Integer Overflow vulnerability in qsvghandler.cpp in Qt qtsvg versions 5.15.1, 6.0.0, 6.0.2, and 6.2, allows local attackers to cause a denial of service (DoS).

Record
CVE-2021-28025
Updated
2026-11-02
EUVDEUVD-2021-14743 No score

Integer Overflow vulnerability in qsvghandler.cpp in Qt qtsvg versions 5.15.1, 6.0.0, 6.0.2, and 6.2, allows local attackers to cause a denial of service (DoS).

Record
EUVD-2021-14743
Updated
2026-11-03
GitHub AdvisoriesGHSA-3w9r-2mqj-cf5c 5.5

Integer Overflow vulnerability in qsvghandler.cpp in Qt qtsvg versions 5.15.1, 6.0.0, 6.0.2, and...

Integer Overflow vulnerability in qsvghandler.cpp in Qt qtsvg versions 5.15.1, 6.0.0, 6.0.2, and 6.2, allows local attackers to cause a denial of service (DoS).

Record
GHSA-3w9r-2mqj-cf5c
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-190
Updated
2026-11-02
OSV 5.5

Integer Overflow vulnerability in qsvghandler.cpp in Qt qtsvg versions 5.15.1, 6.0.0, 6.0.2, and 6.2, allows local attackers to cause a denial of service (DoS).

Record
CVE-2021-28025
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-28025 5.5

Integer Overflow vulnerability in qsvghandler.cpp in Qt qtsvg versions 5.15.1, 6.0.0, 6.0.2, and 6.2, allows local attackers to cause a denial of service (DoS).

Record
DEBIAN-CVE-2021-28025
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-28025 5.5

Integer Overflow vulnerability in qsvghandler.cpp in Qt qtsvg versions 5.15.1, 6.0.0, 6.0.2, and 6.2, allows local attackers to cause a denial of service (DoS).

Record
UBUNTU-CVE-2021-28025
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUSN-8337-1 No score

qtsvg-opensource-src vulnerabilities

It was discovered that QtSvg incorrectly handled certain SVG images. An attacker could possibly use this issue to cause QtSvg to crash, resulting in a denial of service. This issue only affected Ubuntu 16.04 LTS. (CVE-2018-19869)

It was discovered that QtSvg incorrectly handled certain SVG images. An attacker could use this issue to cause QtSvg to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 16.04 LTS and Ubuntu 20.04 LTS. (CVE-2021-3481, CVE-2021-28025, CVE-2021-45930)

It was discovered that QtSvg incorrectly handled certain SVG images. An attacker could use this issue to cause QtSvg to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2023-32573)

Record
USN-8337-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qtsvg-opensource-src
Debian:12
before 5.15.4-2
5.15.4-2
qtsvg-opensource-src
Debian:13
before 5.15.4-2
5.15.4-2
qtsvg-opensource-src
Debian:14
before 5.15.4-2
5.15.4-2
qt4-x11
Ubuntu:14.04:LTS
All versions, plus listed versions
4:4.8.4+dfsg-0ubuntu184:4.8.4+dfsg-0ubuntu194:4.8.4+dfsg-0ubuntu204:4.8.4+dfsg-0ubuntu214:4.8.4+dfsg-0ubuntu224:4.8.5+git192-g085f851+dfsg-2ubuntu34:4.8.5+git192-g085f851+dfsg-2ubuntu44:4.8.5+git192-g085f851+dfsg-2ubuntu4.1
None known
qt4-x11
Ubuntu:16.04:LTS
All versions, plus listed versions
4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu84:4.8.7+dfsg-5ubuntu14:4.8.7+dfsg-5ubuntu2
None known
qtsvg-opensource-src
Ubuntu:Pro:16.04:LTS
before 5.5.1-2ubuntu0.1~esm1, plus listed versions
5.4.2-2build15.5.1-2build1
5.5.1-2ubuntu0.1~esm1
qt4-x11
Ubuntu:18.04:LTS
All versions, plus listed versions
4:4.8.7+dfsg-7ubuntu1
None known
qtsvg-opensource-src
Ubuntu:Pro:20.04:LTS
before 5.12.8-0ubuntu1+esm1, plus listed versions
5.12.4-15.12.5-25.12.5-2build15.12.8-0ubuntu1
5.12.8-0ubuntu1+esm1
qt6-svg
Ubuntu:22.04:LTS
All versions, plus listed versions
6.2.2-2ubuntu16.2.4-1ubuntu1
None known
qt6-svg
Ubuntu:24.04:LTS
All versions, plus listed versions
6.4.2-4ubuntu16.4.2-4ubuntu26.4.2-4ubuntu3
None known
Show 7 moreShow less
Affected packages
PackageAffectedFixed
qt6-svg
Ubuntu:25.10
All versions, plus listed versions
6.8.3-0ubuntu16.9.2-1
None known
qt6-svg
Ubuntu:26.10
All versions, plus listed versions
6.10.2-26.10.2-8ubuntu16.10.2-96.11.2-1
None known
qt6-svg
Ubuntu:26.04:LTS
All versions, plus listed versions
6.9.2-16.9.2-46.9.2-56.10.2-2
None known
qtsvg-opensource-src
Ubuntu:Pro:16.04:LTS
From an advisory covering 5 CVEs
before 5.5.1-2ubuntu0.1~esm1, plus listed versions
5.4.2-2build15.5.1-2build1
5.5.1-2ubuntu0.1~esm1
qtsvg-opensource-src
Ubuntu:Pro:18.04:LTS
From an advisory covering 5 CVEs
before 5.9.5-0ubuntu1.1+esm1, plus listed versions
5.9.1-25.9.2-25.9.2-35.9.3-0ubuntu15.9.4-0ubuntu15.9.5-0ubuntu15.9.5-0ubuntu1.1
5.9.5-0ubuntu1.1+esm1
qtsvg-opensource-src
Ubuntu:Pro:20.04:LTS
From an advisory covering 5 CVEs
before 5.12.8-0ubuntu1+esm1, plus listed versions
5.12.4-15.12.5-25.12.5-2build15.12.8-0ubuntu1
5.12.8-0ubuntu1+esm1
qtsvg-opensource-src
Ubuntu:Pro:22.04:LTS
From an advisory covering 5 CVEs
before 5.15.3-1ubuntu0.1~esm1, plus listed versions
5.15.2-35.15.2-45.15.3-1
5.15.3-1ubuntu0.1~esm1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-28025 is a medium vulnerability (CVSS 5.5) in Qt, published August 11, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 21st percentile. Fixed in qtsvg-opensource-src 5.15.4-2.

References

Show 6 moreShow less
MoveEnter Open