CVE-2021-28114
Cross-site Scripting in Froala WYSIWYG Editor
Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.
- Record
CVE-2021-28114- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.
- Record
CVE-2021-28114- Updated
- 2026-11-02
EUVDEUVD-2021-1491 No score
Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.
- Record
EUVD-2021-1491- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rr6v-h7m8-wc9f
5.4
Cross-site Scripting in Froala WYSIWYG Editor
Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.
- Record
GHSA-rr6v-h7m8-wc9f- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.
- Record
CVE-2021-28114- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-rr6v-h7m8-wc9f
5.4
Cross-site Scripting in Froala WYSIWYG Editor
Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.
- Record
GHSA-rr6v-h7m8-wc9f- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
froala/wysiwyg-editorPackagist |
before 3.2.7 | 3.2.7 |
froala/wysiwyg-editorPackagist |
before 3.2.7, plus listed versions 2.7.1v2.3.5v2.4.0v2.4.0-rc.1v2.4.1 Show 45 moreShow lessv2.4.2v2.5.0v2.5.1v2.6.0v2.6.1v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.7.0v2.7.2v2.7.3v2.7.4v2.7.5v2.7.6v2.8.0v2.8.1v2.8.2v2.8.3v2.8.4v2.8.5v2.9.0v2.9.1v2.9.2v2.9.3v2.9.4v2.9.5v2.9.6v2.9.7v2.9.8v3.0.0v3.0.0-beta.1v3.0.0-beta.2v3.0.0-rc.1v3.0.0-rc.2v3.0.1v3.0.2v3.0.3v3.0.4v3.0.5v3.0.6v3.1.0v3.1.1v3.2.0 |
3.2.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-28114 is a medium vulnerability (CVSS 5.4) in Froala Editor, published July 16, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 52.0%, the 98th percentile. Fixed in froala/wysiwyg-editor 3.2.7.
References
Left out here: 7 versions. The JSON record has them.