Every CVE Search/ Get API key

CVE-2010-3300

Padding oracle attacks

5.9 MediumFix available

It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

0.45%Down 0.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.9

It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.

Record
CVE-2010-3300
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:P/I:N/A:N
Weakness
CWE-649
Updated
2026-11-02
CVE List No score

It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.

Record
CVE-2010-3300
Weakness
CWE-649
Updated
2026-11-02
EUVDEUVD-2021-1544 No score

It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.

Record
EUVD-2021-1544
Updated
2026-11-03
GitHub AdvisoriesGHSA-3gp6-hhfw-4gqx 5.9

Padding oracle attacks

It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.

Record
GHSA-3gp6-hhfw-4gqx
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-649
Updated
2026-11-02
OSVGHSA-3gp6-hhfw-4gqx 5.9

Padding oracle attacks

It was found that all OWASP ESAPI for Java up to version 2.0 RC2 are vulnerable to padding oracle attacks.

Record
GHSA-3gp6-hhfw-4gqx
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-649
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.owasp.esapi:esapi
Maven
before 2.0GA
2.0GA

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-3300 is a medium vulnerability (CVSS 5.9) in Owasp Enterprise Security Api For Java, published June 22, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.45%, the 39th percentile. Fixed in org.owasp.esapi:esapi 2.0GA.

References

MoveEnter Open