Every CVE Search/ Get API key

CVE-2021-36788

Cross-site Scripting in the yoast_seo TYPO3 extension

5.4 MediumFix available

The yoast_seo (aka Yoast SEO) extension before 7.2.3 for TYPO3 allows XSS.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.47%Down 0.2 points since Aug 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.4

The yoast_seo (aka Yoast SEO) extension before 7.2.3 for TYPO3 allows XSS.

Record
CVE-2021-36788
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

The yoast_seo (aka Yoast SEO) extension before 7.2.3 for TYPO3 allows XSS.

Record
CVE-2021-36788
Updated
2026-11-02
EUVDEUVD-2021-1947 No score

The yoast_seo (aka Yoast SEO) extension before 7.2.3 for TYPO3 allows XSS.

Record
EUVD-2021-1947
Updated
2026-11-03
GitHub AdvisoriesGHSA-28w5-j8xj-2xwc 5.4

Cross-site Scripting in the yoast_seo TYPO3 extension

The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.

Record
GHSA-28w5-j8xj-2xwc
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-28w5-j8xj-2xwc 5.4

Cross-site Scripting in the yoast_seo TYPO3 extension

The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.

Record
GHSA-28w5-j8xj-2xwc
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
yoast-seo-for-typo3/yoast_seo
Packagist
before 7.2.3
7.2.3
yoast-seo-for-typo3/yoast_seo
Packagist
before 7.2.3, plus listed versions
7.1.07.1.17.1.27.1.37.2.0
Show 42 moreShow less
7.2.17.2.2v1.0v1.0-betav1.0-rcv1.0.1v1.1.0v1.1.1v1.1.2v1.2.0v1.2.1v1.2.2v1.2.3v1.3.0v1.4.0v1.4.1v2.0.0v2.0.1v2.0.2v2.1.0v3.0.0v3.0.1v3.0.2v3.0.3v3.0.4v3.0.5v4.0.0v4.1.0v5.0.0v5.0.1v5.1.0v5.1.1v6.0.0v6.0.1v7.0.0v7.0.1v7.0.2v7.0.3v7.0.4v7.0.5v7.0.6v7.0.7
7.2.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-36788 is a medium vulnerability (CVSS 5.4) in Yoast Seo, published August 13, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.47%, the 40th percentile. Fixed in yoast-seo-for-typo3/yoast_seo 7.2.3.

References

MoveEnter Open