Every CVE Search/ Get API key

CVE-2021-40656

libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.

8.8 HighFix available

libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.02%Up 0.1 points since Apr 9, 2022
90%50%10%1%

What each source reports

NVD Score used 8.8

libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.

Record
CVE-2021-40656
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.

Record
CVE-2021-40656
Updated
2026-11-02
EUVDEUVD-2021-27830 No score

libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.

Record
EUVD-2021-27830
Updated
2026-11-03
GitHub AdvisoriesGHSA-46hw-rjq2-89r4 8.8

libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.

libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.

Record
GHSA-46hw-rjq2-89r4
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 8.8

libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.

Record
CVE-2021-40656
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-40656 8.8

libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.

Record
DEBIAN-CVE-2021-40656
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-40656 8.8

libsixel before 1.10 is vulnerable to Buffer Overflow in libsixel/src/quant.c:867.

Record
UBUNTU-CVE-2021-40656
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libsixel
Debian:12
before 1.10.3-1
1.10.3-1
libsixel
Debian:13
before 1.10.3-1
1.10.3-1
libsixel
Debian:14
before 1.10.3-1
1.10.3-1
libsixel
Ubuntu:16.04:LTS
All versions, plus listed versions
1.4.2-11.5.2-2
None known
libsixel
Ubuntu:18.04:LTS
All versions, plus listed versions
1.5.2-21.7.3-1
None known
libsixel
Ubuntu:20.04:LTS
All versions, plus listed versions
1.8.2-11.8.2-2.1
None known
libsixel
Ubuntu:22.04:LTS
All versions, plus listed versions
1.8.6-21.10.3-21.10.3-3
None known
libsixel
Ubuntu:24.04:LTS
All versions, plus listed versions
1.10.3-31.10.3-3build1
None known
libsixel
Ubuntu:25.10
All versions, plus listed versions
1.10.5-1
None known
libsixel
Ubuntu:26.10
All versions, plus listed versions
1.10.5-1build11:1.8.7-r2-1
None known
libsixel
Ubuntu:26.04:LTS
All versions, plus listed versions
1.10.5-11.10.5-1build1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-40656 is a high vulnerability (CVSS 8.8) in Libsixel, published April 8, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.02%, the 63rd percentile. Fixed in libsixel 1.10.3-1.

References

MoveEnter Open