Every CVE Search/ Get API key

CVE-2021-44686

calibre before 5.32.0 contains a regular expression that is vulnerable to ReDoS (Regular...

7.5 HighFix available

calibre before 5.32.0 contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service) in html_preprocess_rules in ebooks/conversion/preprocess.py.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

5.21%Up 4.2 points since Dec 7, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

calibre before 5.32.0 contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service) in html_preprocess_rules in ebooks/conversion/preprocess.py.

Record
CVE-2021-44686
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-400
Updated
2026-11-02
CVE List No score

calibre before 5.32.0 contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service) in html_preprocess_rules in ebooks/conversion/preprocess.py.

Record
CVE-2021-44686
Updated
2026-11-02
EUVDEUVD-2021-31502 No score

calibre before 5.32.0 contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service) in html_preprocess_rules in ebooks/conversion/preprocess.py.

Record
EUVD-2021-31502
Updated
2026-11-02
GitHub AdvisoriesGHSA-m6m7-mf2p-99p5 7.5

calibre before 5.32.0 contains a regular expression that is vulnerable to ReDoS (Regular...

calibre before 5.32.0 contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service) in html_preprocess_rules in ebooks/conversion/preprocess.py.

Record
GHSA-m6m7-mf2p-99p5
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400, CWE-770
Updated
2026-11-02
OSV 7.5

calibre before 5.32.0 contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service) in html_preprocess_rules in ebooks/conversion/preprocess.py.

Record
CVE-2021-44686
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2021-44686 7.5

calibre before 5.32.0 contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service) in html_preprocess_rules in ebooks/conversion/preprocess.py.

Record
DEBIAN-CVE-2021-44686
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2021-44686 7.5

calibre before 5.32.0 contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service) in html_preprocess_rules in ebooks/conversion/preprocess.py.

Record
UBUNTU-CVE-2021-44686
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2021-0593 No score

Updated calibre packages fix security vulnerability

ReDoS vulnerability in html_preprocess_rules in ebooks/conversion/preprocess.py

Record
MGASA-2021-0593
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
calibre
Debian:12
before 5.33.0+dfsg-1
5.33.0+dfsg-1
calibre
Debian:13
before 5.33.0+dfsg-1
5.33.0+dfsg-1
calibre
Debian:14
before 5.33.0+dfsg-1
5.33.0+dfsg-1
calibre
Debian:11
From an advisory covering 2 CVEs
before 5.12.0+dfsg-1+deb11u3, plus listed versions
5.12.0+dfsg-15.12.0+dfsg-1+deb11u15.12.0+dfsg-1+deb11u2
5.12.0+dfsg-1+deb11u3
calibre
Mageia:8
before 4.23.0-3.1.mga8
4.23.0-3.1.mga8
calibre
Ubuntu:16.04:LTS
All versions, plus listed versions
2.33.0+dfsg-1build12.38.0+dfsg-12.45.0+dfsg-12.45.0+dfsg-1build12.48.0+dfsg-1
Show 4 moreShow less
2.48.0+dfsg-1build12.54.0+dfsg-12.55.0+dfsg-12.55.0+dfsg-1ubuntu0.2
None known
calibre
Ubuntu:18.04:LTS
All versions, plus listed versions
3.7.0+dfsg-23.7.0+dfsg-2build13.12.0+dfsg-13.13.0+dfsg-13.14.0+dfsg-1
Show 10 moreShow less
3.15.0.1+dfsg-13.16.0+dfsg-13.16.0+dfsg-1build13.17.0+dfsg-13.17.0+dfsg-23.18.0+dfsg-1build13.19.0+dfsg-13.20.0+dfsg-13.21.0+dfsg-13.21.0+dfsg-1build1
None known
calibre
Ubuntu:20.04:LTS
All versions, plus listed versions
3.46.0+dfsg-14.2.0+dfsg-24.3.0+dfsg-14.3.0+dfsg-24.4.0+dfsg-1
Show 14 moreShow less
4.5.0+dfsg-14.5.0+dfsg-24.5.0+dfsg-34.6.0+dfsg-14.7.0+dfsg-14.99.3+dfsg-24.99.4+dfsg-14.99.4+dfsg-1build14.99.4+dfsg+really4.10.0+py3-24.99.4+dfsg+really4.11.2-14.99.4+dfsg+really4.11.2-1build14.99.4+dfsg+really4.12.0-14.99.4+dfsg+really4.12.0-1build14.99.4+dfsg+really4.12.0-1ubuntu1
None known
calibre
Ubuntu:22.04:LTS
All versions, plus listed versions
5.25.0+dfsg-25.33.2+dfsg-15.34.0+dfsg-15.35.0+dfsg-1ubuntu25.37.0+dfsg-15.37.0+dfsg-1build1
None known
calibre
Ubuntu:26.04:LTS
All versions, plus listed versions
8.8.0+ds-3build18.13.0+ds+~0.10.5-38.14.0+ds+~0.10.5-18.15.0+ds+~0.10.5-18.16.0+ds+~0.10.5-2
Show 4 moreShow less
8.16.2+ds+~0.10.5-18.16.2+ds+~0.10.5-28.16.2+ds+~0.10.5-39.2.1+ds+~0.10.5-2build1
None known

History

History
RecordedChangedSources
affected, facts
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2021-44686 is a high vulnerability (CVSS 7.5) in Calibre-ebook Calibre, published December 6, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.21%, the 92nd percentile. Fixed in calibre 5.33.0+dfsg-1.

References

Show 8 moreShow less
MoveEnter Open