CVE-2022-45907
PyTorch vulnerable to arbitrary code execution
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.
- Record
CVE-2022-45907- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List
9.8
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.
- Record
CVE-2022-45907- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-94
- Updated
- 2026-11-02
EUVDEUVD-2022-0340
9.8
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.
- Record
EUVD-2022-0340- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-47fc-vmwq-366v
9.3
PyTorch vulnerable to arbitrary code execution
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely. The fix for this issue is available in version 1.13.1. There is a release checker in issue #89855.
- Record
GHSA-47fc-vmwq-366v- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
OSV
9.8
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.
- Record
CVE-2022-45907- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-47fc-vmwq-366v
9.3
PyTorch vulnerable to arbitrary code execution
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely. The fix for this issue is available in version 1.13.1. There is a release checker in issue #89855.
- Record
GHSA-47fc-vmwq-366v- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2022-45907
9.8
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.
- Record
UBUNTU-CVE-2022-45907- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBIT-pytorch-2022-45907 No score
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.
- Record
BIT-pytorch-2022-45907- Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-45907 No score
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.
- Record
DEBIAN-CVE-2022-45907- Updated
- 2026-11-03
OSVPYSEC-2022-43015 No score
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.
- Record
PYSEC-2022-43015- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
torchPyPI |
through 1.13.0 | 1.13.1 |
pytorchBitnami |
before 1.13.1 | 1.13.1 |
pytorchDebian:12 |
before 1.13.1+dfsg-1 | 1.13.1+dfsg-1 |
pytorchDebian:13 |
before 1.13.1+dfsg-1 | 1.13.1+dfsg-1 |
pytorchDebian:14 |
before 1.13.1+dfsg-1 | 1.13.1+dfsg-1 |
torchPyPI |
before 1.13.1, plus listed versions 1.0.01.0.11.1.01.10.01.10.1 Show 18 moreShow less1.10.21.11.01.12.01.12.11.13.01.2.01.3.01.3.11.4.01.5.01.5.11.6.01.7.01.7.11.8.01.8.11.9.01.9.1 |
1.13.1 |
torchPyPI |
before 1.13.1, plus listed versions 1.0.01.0.11.0.1.post21.1.01.1.0.post2 Show 45 moreShow less1.10.01.10.11.10.21.11.01.12.01.12.11.13.01.2.01.3.01.3.0.post21.3.11.4.01.5.01.5.11.6.01.7.01.7.11.8.01.8.11.9.01.9.1ciflow/periodic/csl/test87519ciflow/periodic/csltest88761ciflow/periodic/csltest88275ciflow/periodic/317eeb8ciflow/periodic/2a6d37dciflow/periodic/3c32ciflow/periodic/054a2fdciflow/periodic/sha-ec5b83malfet/tag-2ef5611malfet/tag-317b1a0malfet/tag-ec6f767nightly-binaryv1.8.0-rc1v1.4.0a0v1.3.0a0v1.2.0a0v1.1.0a0v1.0rc1v1.0rc0v1.0.0a0v0.1.11v0.1.10v0.1.9v0.1.8 |
1.13.1 |
pytorchUbuntu:22.04:LTS |
All versions, plus listed versions 1.7.1-71.8.1-4 |
None known |
pytorchUbuntu:25.10 |
All versions, plus listed versions 2.6.0+dfsg-5build12.6.0+dfsg-7 |
None known |
pytorchUbuntu:26.10 |
All versions, plus listed versions 2.9.1+dfsg-1~exp1ubuntu22.12.1+dfsg-1 |
None known |
pytorchUbuntu:26.04:LTS |
All versions, plus listed versions 2.6.0+dfsg-72.6.0+dfsg-92.9.1+dfsg-1~exp1ubuntu2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-45907 is a critical vulnerability (CVSS 9.8) in Linuxfoundation Pytorch, published November 26, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.33%, the 71st percentile. Fixed in torch 1.13.1.
References
github.com/pytorch/pytorch/issues/88868
github.com/pytorch/pytorch/commit/767f6aa49fe20a2766b9843d01e3b7f7793df6a3
nvd.nist.gov/vuln/detail/CVE-2022-45907
github.com/pytorch/pytorch/issues/89855
github.com/pytorch/pytorch/pull/89189
github.com/pytorch/pytorch/releases/tag/v1.13.1
Show 7 moreShow less
github.com/pypa/advisory-database/tree/main/vulns/torch/PYSEC-2022-43015.yaml
github.com/advisories/GHSA-47fc-vmwq-366v
github.com/CVEProject/cvelistV5/tree/main/cves/2022/45xxx/CVE-2022-45907.json
security-tracker.debian.org/tracker/CVE-2022-45907
github.com/pytorch/pytorch
ubuntu.com/security/CVE-2022-45907
cve.org/CVERecord?id=CVE-2022-45907
Left out here: 7 versions. The JSON record has them.