Every CVE Search/ Get API key

CVE-2020-24025

Improper Certificate Validation in node-sass

5.3 MediumFix available

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

0.83%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.3

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.

Record
CVE-2020-24025
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.

Record
CVE-2020-24025
Updated
2026-11-02
EUVDEUVD-2022-1165 No score

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.

Record
EUVD-2022-1165
Updated
2026-11-03
GitHub AdvisoriesGHSA-r8f7-9pfq-mjmv 5.3

Improper Certificate Validation in node-sass

Certificate validation in node-sass 2.0.0 to 6.0.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.

Record
GHSA-r8f7-9pfq-mjmv
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-295
Updated
2026-11-02
OSVAZL-27653 5.3

CVE-2020-24025 affecting package reaper for versions less than 3.1.1-9

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.

Record
AZL-27653
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSV 5.3

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.

Record
CVE-2020-24025
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2020-24025 5.3

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.

Record
DEBIAN-CVE-2020-24025
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVGHSA-r8f7-9pfq-mjmv 5.3

Improper Certificate Validation in node-sass

Certificate validation in node-sass 2.0.0 to 6.0.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.

Record
GHSA-r8f7-9pfq-mjmv
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-295
Updated
2026-11-02
OSVUBUNTU-CVE-2020-24025 5.3

Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path.

Record
UBUNTU-CVE-2020-24025
CVSS 3.1
5.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVCLSA-2026-1788517165 No score

TuxCare security update for node-sass (1 CVE)

TuxCare rebuilt node-sass to address 1 CVE. Fixed in 6.0.1-tuxcare.1.

Record
CLSA-2026-1788517165
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
node-sass
npm
2.0.0 up to 7.0.0
7.0.0
reaper
Azure Linux:2
before 3.1.1-9
3.1.1-9
node-sass
TuxCare:npm
6.0.1-tuxcare.0 up to 6.0.1-tuxcare.1, plus listed versions
6.0.1
6.0.1-tuxcare.1
node-node-sass
Debian:12
before 7.0.1+git20211229.3bb51da+dfsg-1
7.0.1+git20211229.3bb51da+dfsg-1
node-node-sass
Debian:13
before 7.0.1+git20211229.3bb51da+dfsg-1
7.0.1+git20211229.3bb51da+dfsg-1
node-node-sass
Debian:14
before 7.0.1+git20211229.3bb51da+dfsg-1
7.0.1+git20211229.3bb51da+dfsg-1
node-node-sass
Ubuntu:20.04:LTS
All versions, plus listed versions
4.12.0-24.13.1-14.13.1-3
None known
node-node-sass
Ubuntu:22.04:LTS
All versions, plus listed versions
4.14.1+git20200512.e1fc158+dfsg-44.14.1+git20200512.e1fc158+dfsg-67.0.1+git20211229.3bb51da+dfsg-1
None known
node-node-sass
Ubuntu:24.04:LTS
All versions, plus listed versions
7.0.3+git20221109.ee13eb9+dfsg-29.0.0+git20240131.6081731+dfsg-1
None known
node-node-sass
Ubuntu:25.10
All versions, plus listed versions
9.0.0+git20240131.6081731+dfsg-3
None known
node-node-sass
Ubuntu:26.10
All versions, plus listed versions
9.0.0+git20240724.107ded9+dfsg-1build19.0.0+git20240724.107ded9+dfsg-1build2
None known
node-node-sass
Ubuntu:26.04:LTS
All versions, plus listed versions
9.0.0+git20240131.6081731+dfsg-39.0.0+git20240724.107ded9+dfsg-1build1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-24025 is a medium vulnerability (CVSS 5.3) in Sass-lang Node-sass, published January 11, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.83%, the 57th percentile. Fixed in node-sass 7.0.0.

References

Show 5 moreShow less
MoveEnter Open