Every CVE Search/ Get API key

CVE-2022-0772

Cross-site Scripting (XSS) - Stored in librenms/librenms

4.7 MediumFix available

Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.2.2.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

0.62%Down 0.3 points since Feb 28, 2022
90%50%10%1%

What each source reports

CVE List Score used 4.7

Cross-site Scripting (XSS) - Stored in librenms/librenms

Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.2.2.

Record
CVE-2022-0772
CVSS 3.0
4.7 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-1206 4.7

Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.2.2.

Record
EUVD-2022-1206
CVSS 3.0
4.7 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-vhm6-gw82-6f8j 4.8

Cross site scripting in LibreNMS

LibreNMS prior to version 22.2.2 is vulnerable to cross-site scripting.

Record
GHSA-vhm6-gw82-6f8j
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 4.8

Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.2.2.

Record
CVE-2022-0772
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
4.7 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 4.7

Cross-site Scripting (XSS) - Stored in librenms/librenms

Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.2.2.

Record
CVE-2022-0772
CVSS 3.0
4.7 MediumCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-vhm6-gw82-6f8j 4.8

Cross site scripting in LibreNMS

LibreNMS prior to version 22.2.2 is vulnerable to cross-site scripting.

Record
GHSA-vhm6-gw82-6f8j
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
librenms/librenms
Packagist
before 22.2.2
22.2.2
librenms/librenms
Packagist
before 22.2.2, plus listed versions
1.191.201.20.11.211.22
Show 45 moreShow less
1.22.011.231.241.251.261.271.281.291.301.30.011.311.31.011.31.021.31.031.321.32.011.331.33.011.341.351.361.36.011.371.381.391.401.411.421.42.011.431.441.451.461.471.481.48.11.491.501.50.11.511.521.531.53.11.541.55
22.2.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-0772 is a medium vulnerability (CVSS 4.7) in Librenms, published February 27, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.62%, the 50th percentile. Fixed in librenms/librenms 22.2.2.

References

This page doesn't list everything

Left out here: 41 versions. The JSON record has them.

MoveEnter Open