CVE-2021-26598
Incorrect Access Control in ImpressCMS
ImpressCMS before 1.4.3 has Incorrect Access Control because include/findusers.php allows access by unauthenticated attackers (who are, by design, able to have a security token).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.3
ImpressCMS before 1.4.3 has Incorrect Access Control because include/findusers.php allows access by unauthenticated attackers (who are, by design, able to have a security token).
- Record
CVE-2021-26598- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-287
- Updated
- 2026-11-02
CVE List No score
ImpressCMS before 1.4.3 has Incorrect Access Control because include/findusers.php allows access by unauthenticated attackers (who are, by design, able to have a security token).
- Record
CVE-2021-26598- Updated
- 2026-11-02
EUVDEUVD-2022-1301 No score
ImpressCMS before 1.4.3 has Incorrect Access Control because include/findusers.php allows access by unauthenticated attackers (who are, by design, able to have a security token).
- Record
EUVD-2022-1301- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-48p3-xfvw-g59c
5.3
Incorrect Access Control in ImpressCMS
ImpressCMS before 1.4.3 has Incorrect Access Control because include/findusers.php allows access by unauthenticated attackers (who are, by design, able to have a security token).
- Record
GHSA-48p3-xfvw-g59c- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-287
- Updated
- 2026-11-02
OSV
5.3
ImpressCMS before 1.4.3 has Incorrect Access Control because include/findusers.php allows access by unauthenticated attackers (who are, by design, able to have a security token).
- Record
CVE-2021-26598- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-48p3-xfvw-g59c
5.3
Incorrect Access Control in ImpressCMS
ImpressCMS before 1.4.3 has Incorrect Access Control because include/findusers.php allows access by unauthenticated attackers (who are, by design, able to have a security token).
- Record
GHSA-48p3-xfvw-g59c- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - Weakness
- CWE-287
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
impresscms/impresscmsPackagist |
before 1.4.3 | 1.4.3 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Nuclei | ImpressCMS <1.4.3 - Incorrect Authorization |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, Nuclei, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-26598 is a medium vulnerability (CVSS 5.3) in Impresscms, published March 28, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 10.5%, the 95th percentile. Fixed in impresscms/impresscms 1.4.3.
References
hackerone.com/reports/1081137
packetstormsecurity.com/files/166403/ImpressCMS-1.4.2-Incorrect-Access-Control.html
karmainsecurity.com/KIS-2022-03
seclists.org/fulldisclosure/2022/Mar/45
nvd.nist.gov/vuln/detail/CVE-2021-26598
github.com/ImpressCMS/impresscms/pull/967
github.com/ImpressCMS/impresscms/releases/tag/v1.4.3
github.com/advisories/GHSA-48p3-xfvw-g59c
github.com/ImpressCMS/impresscms