CVE-2021-26600
Type Confusion in ImpressCMS
ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).
- Record
CVE-2021-26600- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-843
- Updated
- 2026-11-02
CVE List No score
ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).
- Record
CVE-2021-26600- Updated
- 2026-11-02
EUVDEUVD-2022-1471 No score
ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).
- Record
EUVD-2022-1471- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m8xh-cqc2-5q6f
9.8
Type Confusion in ImpressCMS
ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).
- Record
GHSA-m8xh-cqc2-5q6f- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-843
- Updated
- 2026-11-02
OSV
9.8
ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).
- Record
CVE-2021-26600- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-m8xh-cqc2-5q6f
9.8
Type Confusion in ImpressCMS
ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).
- Record
GHSA-m8xh-cqc2-5q6f- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-843
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
impresscms/impresscmsPackagist |
before 1.4.3 | 1.4.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-26600 is a critical vulnerability (CVSS 9.8) in Impresscms, published March 28, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.63%, the 92nd percentile. Fixed in impresscms/impresscms 1.4.3.
References
hackerone.com/reports/1081986
packetstormsecurity.com/files/166393/ImpressCMS-1.4.2-Authentication-Bypass.html
seclists.org/fulldisclosure/2022/Mar/43
karmainsecurity.com/KIS-2022-01
nvd.nist.gov/vuln/detail/CVE-2021-26600
github.com/ImpressCMS/impresscms/releases/tag/v1.4.3
github.com/advisories/GHSA-m8xh-cqc2-5q6f
github.com/ImpressCMS/impresscms