Every CVE Search/ Get API key

CVE-2022-28367

Cross-site Scripting in OWASP AntiSamy

6.1 MediumFix available

OWASP AntiSamy before 1.6.6 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.01%Up 0.1 points since Apr 22, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

OWASP AntiSamy before 1.6.6 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content.

Record
CVE-2022-28367
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

OWASP AntiSamy before 1.6.6 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content.

Record
CVE-2022-28367
Updated
2026-11-02
EUVDEUVD-2022-1609 No score

OWASP AntiSamy before 1.6.6 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content.

Record
EUVD-2022-1609
Updated
2026-11-03
GitHub AdvisoriesGHSA-3pqg-4rqg-pg9g 6.1

Cross-site Scripting in OWASP AntiSamy

OWASP AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. AntiSamy before 1.6.6 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content.

Record
GHSA-3pqg-4rqg-pg9g
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-3pqg-4rqg-pg9g 6.1

Cross-site Scripting in OWASP AntiSamy

OWASP AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. AntiSamy before 1.6.6 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content.

Record
GHSA-3pqg-4rqg-pg9g
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2022-28367 6.1

OWASP AntiSamy before 1.6.6 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content.

Record
UBUNTU-CVE-2022-28367
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSV No score

OWASP AntiSamy before 1.6.6 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content.

Record
CVE-2022-28367
Updated
2026-11-02
OSVDEBIAN-CVE-2022-28367 No score

OWASP AntiSamy before 1.6.6 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content.

Record
DEBIAN-CVE-2022-28367
Updated
2026-11-03

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.owasp.antisamy:antisamy
Maven
before 1.6.6
1.6.6
libowasp-antisamy-java
Debian:12
All versions, plus listed versions
1.5.3+dfsg-1.11.7.4-11.7.8-1
None known
libowasp-antisamy-java
Debian:13
before 1.7.4-1
1.7.4-1
libowasp-antisamy-java
Debian:14
before 1.7.4-1
1.7.4-1
org.owasp.antisamy:antisamy
Maven
before 1.6.6, plus listed versions
1.4.21.4.31.4.41.4.51.5
Show 18 moreShow less
1.5.11.5.101.5.111.5.121.5.131.5.21.5.31.5.51.5.61.5.71.5.81.5.91.6.01.6.11.6.21.6.31.6.41.6.5
1.6.6
libowasp-antisamy-java
Ubuntu:16.04:LTS
All versions, plus listed versions
1.5.3+dfsg-1
None known
libowasp-antisamy-java
Ubuntu:18.04:LTS
All versions, plus listed versions
1.5.3+dfsg-1
None known
libowasp-antisamy-java
Ubuntu:20.04:LTS
All versions, plus listed versions
1.5.3+dfsg-1
None known
libowasp-antisamy-java
Ubuntu:22.04:LTS
All versions, plus listed versions
1.5.3+dfsg-1.1
None known
libowasp-antisamy-java
Ubuntu:24.04:LTS
All versions, plus listed versions
1.5.3+dfsg-1.11.7.4-1
None known
libowasp-antisamy-java
Ubuntu:25.10
All versions, plus listed versions
1.7.4-1
None known
libowasp-antisamy-java
Ubuntu:26.10
All versions, plus listed versions
1.7.4-1
None known
libowasp-antisamy-java
Ubuntu:26.04:LTS
All versions, plus listed versions
1.7.4-1
None known

History

History
RecordedChangedSources
affectedOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-28367 is a medium vulnerability (CVSS 6.1) in Antisamy Project Antisamy, published April 21, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in org.owasp.antisamy:antisamy 1.6.6.

References

Show 4 moreShow less
MoveEnter Open