CVE-2022-28366
Denial of service in HtmlUnit-Neko
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
- Record
CVE-2022-28366- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Updated
- 2026-11-02
CVE List No score
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
- Record
CVE-2022-28366- Updated
- 2026-11-02
EUVDEUVD-2022-1739 No score
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
- Record
EUVD-2022-1739- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g9hh-vvx3-v37v
7.5
Denial of service in HtmlUnit-Neko
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24939.
- Record
GHSA-g9hh-vvx3-v37v- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-28366
7.5
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
- Record
DEBIAN-CVE-2022-28366- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-03
OSVGHSA-g9hh-vvx3-v37v
7.5
Denial of service in HtmlUnit-Neko
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24939.
- Record
GHSA-g9hh-vvx3-v37v- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-28366
7.5
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
- Record
UBUNTU-CVE-2022-28366- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSV No score
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
- Record
CVE-2022-28366- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:12022-1 No score
nekohtml-1.9.22.noko2-1.1 on GA media
These are all security issues fixed in the nekohtml-1.9.22.noko2-1.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:12022-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
net.sourceforge.htmlunit:neko-htmlunitMaven |
before 2.27 | 2.27 |
libowasp-antisamy-javaDebian:12 |
All versions, plus listed versions 1.5.3+dfsg-1.11.7.4-11.7.8-1 |
None known |
libowasp-antisamy-javaDebian:13 |
before 1.7.4-1 | 1.7.4-1 |
libowasp-antisamy-javaDebian:14 |
before 1.7.4-1 | 1.7.4-1 |
net.sourceforge.htmlunit:neko-htmlunitMaven |
before 2.27, plus listed versions 2.212.232.242.25 |
2.27 |
libowasp-antisamy-javaUbuntu:16.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1 |
None known |
libowasp-antisamy-javaUbuntu:18.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1 |
None known |
libowasp-antisamy-javaUbuntu:20.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1 |
None known |
libowasp-antisamy-javaUbuntu:22.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1.1 |
None known |
libowasp-antisamy-javaUbuntu:24.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1.11.7.4-1 |
None known |
libowasp-antisamy-javaUbuntu:25.10 |
All versions, plus listed versions 1.7.4-1 |
None known |
libowasp-antisamy-javaUbuntu:26.10 |
All versions, plus listed versions 1.7.4-1 |
None known |
libowasp-antisamy-javaUbuntu:26.04:LTS |
All versions, plus listed versions 1.7.4-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-28366 is a high vulnerability (CVSS 7.5) in Antisamy Project Antisamy, published April 21, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.18%, the 82nd percentile. Fixed in net.sourceforge.htmlunit:neko-htmlunit 2.27.
References
github.com/nahsra/antisamy/releases/tag/v1.6.6
search.maven.org/artifact/net.sourceforge.htmlunit/neko-htmlunit
sourceforge.net/projects/htmlunit/files/htmlunit/2.27
nvd.nist.gov/vuln/detail/CVE-2022-28366
github.com/advisories/GHSA-g9hh-vvx3-v37v
github.com/CVEProject/cvelistV5/tree/main/cves/2022/28xxx/CVE-2022-28366.json