CVE-2022-29577
Cross-site Scripting in OWASP AntiSamy
OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content. NOTE: this issue exists because of an incomplete fix for CVE-2022-28367.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content. NOTE: this issue exists because of an incomplete fix for CVE-2022-28367.
- Record
CVE-2022-29577- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content. NOTE: this issue exists because of an incomplete fix for CVE-2022-28367.
- Record
CVE-2022-29577- Updated
- 2026-11-02
EUVDEUVD-2022-1842 No score
OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content. NOTE: this issue exists because of an incomplete fix for CVE-2022-28367.
- Record
EUVD-2022-1842- Updated
- 2026-11-02
GitHub AdvisoriesGHSA-vp37-2f9p-3vr3
6.1
Cross-site Scripting in OWASP AntiSamy
AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content. NOTE: this issue exists because of an incomplete fix for CVE-2022-28367.
- Record
GHSA-vp37-2f9p-3vr3- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-vp37-2f9p-3vr3
6.1
Cross-site Scripting in OWASP AntiSamy
AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content. NOTE: this issue exists because of an incomplete fix for CVE-2022-28367.
- Record
GHSA-vp37-2f9p-3vr3- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-29577
6.1
OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content. NOTE: this issue exists because of an incomplete fix for CVE-2022-28367.
- Record
UBUNTU-CVE-2022-29577- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSV No score
OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content. NOTE: this issue exists because of an incomplete fix for CVE-2022-28367.
- Record
CVE-2022-29577- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.owasp.antisamy:antisamyMaven |
before 1.6.7 | 1.6.7 |
org.owasp.antisamy:antisamyMaven |
before 1.6.7, plus listed versions 1.4.21.4.31.4.41.4.51.5 Show 20 moreShow less1.5.11.5.101.5.111.5.121.5.131.5.21.5.31.5.51.5.61.5.71.5.81.5.91.6.01.6.11.6.21.6.31.6.41.6.51.6.61.6.6.1 |
1.6.7 |
libowasp-antisamy-javaUbuntu:16.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1 |
None known |
libowasp-antisamy-javaUbuntu:18.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1 |
None known |
libowasp-antisamy-javaUbuntu:20.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1 |
None known |
libowasp-antisamy-javaUbuntu:22.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1.1 |
None known |
libowasp-antisamy-javaUbuntu:24.04:LTS |
All versions, plus listed versions 1.5.3+dfsg-1.11.7.4-1 |
None known |
libowasp-antisamy-javaUbuntu:25.10 |
All versions, plus listed versions 1.7.4-1 |
None known |
libowasp-antisamy-javaUbuntu:26.10 |
All versions, plus listed versions 1.7.4-1 |
None known |
libowasp-antisamy-javaUbuntu:26.04:LTS |
All versions, plus listed versions 1.7.4-1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | shoucheng3/nahsra__antisamy_CVE-2022-29577_1-6-6-1 | 2025-08-17 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-29577 is a medium vulnerability (CVSS 6.1) in Antisamy Project Antisamy, published April 21, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.33%, the 71st percentile. Fixed in org.owasp.antisamy:antisamy 1.6.7.
References
github.com/nahsra/antisamy/releases/tag/v1.6.7
github.com/nahsra/antisamy/commit/32e273507da0e964b58c50fd8a4c94c9d9363af0
oracle.com/security-alerts/cpujul2022.html
nvd.nist.gov/vuln/detail/CVE-2022-29577
github.com/advisories/GHSA-vp37-2f9p-3vr3
github.com/CVEProject/cvelistV5/tree/main/cves/2022/29xxx/CVE-2022-29577.json
github.com/nahsra/antisamy
ubuntu.com/security/CVE-2022-29577
cve.org/CVERecord?id=CVE-2022-29577