CVE-2021-37517
Access Control vulnerability in Dolibarr
An Access Control vulnerability exists in Dolibarr ERP/CRM 13.0.2, fixed version is 14.0.0,in the forgot-password function becuase the application allows email addresses as usernames, which can cause a Denial of Service.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
An Access Control vulnerability exists in Dolibarr ERP/CRM 13.0.2, fixed version is 14.0.0,in the forgot-password function becuase the application allows email addresses as usernames, which can cause a Denial of Service.
- Record
CVE-2021-37517- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-863
- Updated
- 2026-11-02
CVE List No score
An Access Control vulnerability exists in Dolibarr ERP/CRM 13.0.2, fixed version is 14.0.0,in the forgot-password function becuase the application allows email addresses as usernames, which can cause a Denial of Service.
- Record
CVE-2021-37517- Updated
- 2026-11-02
EUVDEUVD-2022-1873 No score
An Access Control vulnerability exists in Dolibarr ERP/CRM 13.0.2, fixed version is 14.0.0,in the forgot-password function becuase the application allows email addresses as usernames, which can cause a Denial of Service.
- Record
EUVD-2022-1873- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-xw7v-qrhc-jjg2
7.5
Access Control vulnerability in Dolibarr
An Access Control vulnerability exists in Dolibarr ERP/CRM 13.0.2, fixed version is 14.0.1, in the forgot-password function becuase the application allows email addresses as usernames, which can cause a Denial of Service.
- Record
GHSA-xw7v-qrhc-jjg2- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-863
- Updated
- 2026-11-02
OSV
7.5
An Access Control vulnerability exists in Dolibarr ERP/CRM 13.0.2, fixed version is 14.0.0,in the forgot-password function becuase the application allows email addresses as usernames, which can cause a Denial of Service.
- Record
CVE-2021-37517- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVGHSA-xw7v-qrhc-jjg2
7.5
Access Control vulnerability in Dolibarr
An Access Control vulnerability exists in Dolibarr ERP/CRM 13.0.2, fixed version is 14.0.1, in the forgot-password function becuase the application allows email addresses as usernames, which can cause a Denial of Service.
- Record
GHSA-xw7v-qrhc-jjg2- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-863
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2021-37517
7.5
An Access Control vulnerability exists in Dolibarr ERP/CRM 13.0.2, fixed version is 14.0.0,in the forgot-password function becuase the application allows email addresses as usernames, which can cause a Denial of Service.
- Record
UBUNTU-CVE-2021-37517- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVBIT-dolibarr-2021-37517 No score
An Access Control vulnerability exists in Dolibarr ERP/CRM 13.0.2, fixed version is 14.0.0,in the forgot-password function becuase the application allows email addresses as usernames, which can cause a Denial of Service.
- Record
BIT-dolibarr-2021-37517- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
dolibarr/dolibarrPackagist |
before 14.0.1 | 14.0.1 |
dolibarrBitnami |
13.0.2 to 13.0.2 | None known |
dolibarr/dolibarrPackagist |
before 14.0.1, plus listed versions 10.0.010.0.110.0.210.0.310.0.4 Show 45 moreShow less10.0.510.0.610.0.711.0.011.0.111.0.211.0.311.0.411.0.512.0.012.0.112.0.212.0.312.0.412.0.513.0.013.0.113.0.213.0.313.0.413.0.514.0.03.6.03.6.0-beta3.6.13.6.23.6.33.6.43.6.53.6.63.7.03.7.13.7.23.7.33.7.43.8.03.8.0-beta3.8.13.8.23.8.33.8.43.9.03.9.0-rc3.9.0-rc23.9.1 |
14.0.1 |
dolibarrUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 3.5.5+dfsg1-23.5.7+dfsg1-13.5.8+dfsg1-13.5.8+dfsg1-1ubuntu13.5.8+dfsg1-1ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2021-37517 is a high vulnerability (CVSS 7.5) in Dolibarr Erp\/crm, published March 31, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.98%, the 62nd percentile. Fixed in dolibarr/dolibarr 14.0.1.
References
github.com/Dolibarr/dolibarr/commit/b57eb8284e830e30eefb26e3c5ede076ea24037c
nvd.nist.gov/vuln/detail/CVE-2021-37517
github.com/Dolibarr/dolibarr/releases/tag/14.0.1
github.com/advisories/GHSA-xw7v-qrhc-jjg2
github.com/Dolibarr/dolibarr
ubuntu.com/security/CVE-2021-37517
cve.org/CVERecord?id=CVE-2021-37517
Left out here: 53 versions. The JSON record has them.