Every CVE Search/ Get API key

CVE-2015-6524

Improper Input Validation in Apache ActiveMQ

5.0 MediumFix available

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

Exploit likelihood

8.24%Up 7.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

Record
CVE-2015-6524
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-255
Updated
2026-11-02
CVE List No score

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

Record
CVE-2015-6524
Updated
2026-11-02
EUVDEUVD-2022-1890 No score

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

Record
EUVD-2022-1890
Updated
2026-11-03
GitHub AdvisoriesGHSA-23cr-5hr4-rgwv No score

Improper Input Validation in Apache ActiveMQ

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

Record
GHSA-23cr-5hr4-rgwv
Weakness
CWE-20
Updated
2026-11-02
OSV No score

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

Record
CVE-2015-6524
Updated
2026-11-02
OSVDEBIAN-CVE-2015-6524 No score

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

Record
DEBIAN-CVE-2015-6524
Updated
2026-11-02
OSVGHSA-23cr-5hr4-rgwv No score

Improper Input Validation in Apache ActiveMQ

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

Record
GHSA-23cr-5hr4-rgwv
Weakness
CWE-20
Updated
2026-11-02
OSVUBUNTU-CVE-2015-6524 No score

The LDAPLoginModule implementation in the Java Authentication and Authorization Service (JAAS) in Apache ActiveMQ 5.x before 5.10.1 allows wildcard operators in usernames, which allows remote attackers to obtain credentials via a brute force attack. NOTE: this identifier was SPLIT from CVE-2014-3612 per ADT2 due to different vulnerability types.

Record
UBUNTU-CVE-2015-6524
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.activemq:activemq-broker
Maven
5.0.0 to 5.10.1
5.10.2
org.apache.activemq:activemq-jaas
Maven
5.0.0 to 5.10.1
5.10.2
activemq
Debian:12
before 5.6.0+dfsg1-4
5.6.0+dfsg1-4
activemq
Debian:13
before 5.6.0+dfsg1-4
5.6.0+dfsg1-4
org.apache.activemq:activemq-broker
Maven
5.0.0 up to 5.10.2, plus listed versions
5.10.05.10.15.8.05.9.05.9.1
5.10.2
org.apache.activemq:activemq-jaas
Maven
5.0.0 up to 5.10.2, plus listed versions
5.1.05.10.05.10.15.2.05.3.0
Show 13 moreShow less
5.3.15.3.25.4.05.4.15.4.25.4.35.5.05.5.15.6.05.7.05.8.05.9.05.9.1
5.10.2
activemq
Ubuntu:14.04:LTS
before 5.6.0+dfsg-1+deb7u1build0.14.04.1, plus listed versions
5.6.0+dfsg-1
5.6.0+dfsg-1+deb7u1build0.14.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2015-6524 is a medium vulnerability (CVSS 5.0) in Apache Activemq, published August 24, 2015. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.24%, the 94th percentile. Fixed in org.apache.activemq:activemq-broker 5.10.2.

References

Show 4 moreShow less
MoveEnter Open