Every CVE Search/ Get API key

CVE-2013-1607

PDFKit Improper Input Validation vulnerability

9.8 CriticalFix available

Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.67%Up 1.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability

Record
CVE-2013-1607
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability

Record
CVE-2013-1607
Updated
2026-11-02
EUVDEUVD-2022-2153 No score

Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability

Record
EUVD-2022-2153
Updated
2026-11-03
GitHub AdvisoriesGHSA-39v7-xpq4-8884 9.8

PDFKit Improper Input Validation vulnerability

Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability

Record
GHSA-39v7-xpq4-8884
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-39v7-xpq4-8884 9.8

PDFKit Improper Input Validation vulnerability

Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability

Record
GHSA-39v7-xpq4-8884
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pdfkit
RubyGems
before 0.5.3
0.5.3
pdfkit
RubyGems
before 0.5.3, plus listed versions
0.1.00.1.10.2.00.2.10.2.2
Show 15 moreShow less
0.2.30.3.00.3.10.3.20.3.30.4.00.4.10.4.20.4.30.4.40.4.50.4.60.5.00.5.10.5.2
0.5.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-1607 is a critical vulnerability (CVSS 9.8) in Pdfkit Project Pdfkit, published February 11, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.67%, the 85th percentile. Fixed in pdfkit 0.5.3.

References

MoveEnter Open