Every CVE Search/ Get API key

CVE-2013-4662

CiviCRM SQL injection vulnerability via Quick Search API

6.5 MediumFix available

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.

Exploit likelihood

1.01%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.

Record
CVE-2013-4662
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.

Record
CVE-2013-4662
Updated
2026-11-02
EUVDEUVD-2022-2290 No score

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.

Record
EUVD-2022-2290
Updated
2026-11-03
GitHub AdvisoriesGHSA-4465-r2hg-v4rj No score

CiviCRM SQL injection vulnerability via Quick Search API

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.

Record
GHSA-4465-r2hg-v4rj
Weakness
CWE-89
Updated
2026-11-02
OSVGHSA-4465-r2hg-v4rj No score

CiviCRM SQL injection vulnerability via Quick Search API

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.

Record
GHSA-4465-r2hg-v4rj
Weakness
CWE-89
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
civicrm/civicrm-core
Packagist
4.2.0 up to 4.2.9
4.2.9
civicrm/civicrm-core
Packagist
4.3.0 up to 4.3.3
4.3.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-4662 is a medium vulnerability (CVSS 6.5) in Civicrm, published January 29, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in civicrm/civicrm-core 4.2.9.

References

MoveEnter Open