CVE-2014-3503
Apache Syncope uses a weak PNRG
Apache Syncope 1.1.x before 1.1.8 uses weak random values to generate passwords, which makes it easier for remote attackers to guess the password via a brute force attack.
Exploit likelihood
What each source reports
NVD Score used
5.0
Apache Syncope 1.1.x before 1.1.8 uses weak random values to generate passwords, which makes it easier for remote attackers to guess the password via a brute force attack.
- Record
CVE-2014-3503- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-310
- Updated
- 2026-11-02
CVE List No score
Apache Syncope 1.1.x before 1.1.8 uses weak random values to generate passwords, which makes it easier for remote attackers to guess the password via a brute force attack.
- Record
CVE-2014-3503- Updated
- 2026-11-02
EUVDEUVD-2022-2354 No score
Apache Syncope 1.1.x before 1.1.8 uses weak random values to generate passwords, which makes it easier for remote attackers to guess the password via a brute force attack.
- Record
EUVD-2022-2354- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4c72-mrhf-23cg No score
Apache Syncope uses a weak PNRG
Apache Syncope 1.1.x before 1.1.8 uses weak random values to generate passwords, which makes it easier for remote attackers to guess the password via a brute force attack.
- Record
GHSA-4c72-mrhf-23cg- Weakness
- CWE-338
- Updated
- 2026-11-02
OSVGHSA-4c72-mrhf-23cg No score
Apache Syncope uses a weak PNRG
Apache Syncope 1.1.x before 1.1.8 uses weak random values to generate passwords, which makes it easier for remote attackers to guess the password via a brute force attack.
- Record
GHSA-4c72-mrhf-23cg- Weakness
- CWE-338
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.syncope:syncopeMaven |
1.1.0 up to 1.1.8 | 1.1.8 |
org.apache.syncope:syncopeMaven |
1.1.0 up to 1.1.8, plus listed versions 1.1.11.1.21.1.31.1.41.1.51.1.61.1.7 |
1.1.8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2014-3503 is a medium vulnerability (CVSS 5.0) in Apache Syncope, published July 11, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.02%, the 93rd percentile. Fixed in org.apache.syncope:syncope 1.1.8.
References
securityfocus.com/archive/1/532669/100/0/threaded
syncope.apache.org/security.html
packetstormsecurity.com/files/127375/Apache-Syncope-Insecure-Password-Generation.html
securityfocus.com/bid/68431
nvd.nist.gov/vuln/detail/CVE-2014-3503
github.com/apache/syncope/commit/8e0045925a387ee211832c7e0709dd418cda1ad3