Every CVE Search/ Get API key

CVE-2014-3600

Improper Restriction of XML External Entity Reference in Apache ActiveMQ

9.8 CriticalFix available

XML external entity (XXE) vulnerability in Apache ActiveMQ 5.x before 5.10.1 allows remote consumers to have unspecified impact via vectors involving an XPath based selector when dequeuing XML messages.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

8.18%Up 6.4 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

XML external entity (XXE) vulnerability in Apache ActiveMQ 5.x before 5.10.1 allows remote consumers to have unspecified impact via vectors involving an XPath based selector when dequeuing XML messages.

Record
CVE-2014-3600
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-611
Updated
2026-11-02
CVE List No score

XML external entity (XXE) vulnerability in Apache ActiveMQ 5.x before 5.10.1 allows remote consumers to have unspecified impact via vectors involving an XPath based selector when dequeuing XML messages.

Record
CVE-2014-3600
Updated
2026-11-02
EUVDEUVD-2022-2450 No score

XML external entity (XXE) vulnerability in Apache ActiveMQ 5.x before 5.10.1 allows remote consumers to have unspecified impact via vectors involving an XPath based selector when dequeuing XML messages.

Record
EUVD-2022-2450
Updated
2026-11-03
GitHub AdvisoriesGHSA-4vhf-2hv7-8mrx 9.8

Improper Restriction of XML External Entity Reference in Apache ActiveMQ

XML external entity (XXE) vulnerability in Apache ActiveMQ 5.x before 5.10.1 allows remote consumers to have unspecified impact via vectors involving an XPath based selector when dequeuing XML messages.

Record
GHSA-4vhf-2hv7-8mrx
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-611
Updated
2026-11-02
OSV 9.8

XML external entity (XXE) vulnerability in Apache ActiveMQ 5.x before 5.10.1 allows remote consumers to have unspecified impact via vectors involving an XPath based selector when dequeuing XML messages.

Record
CVE-2014-3600
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2014-3600 9.8

XML external entity (XXE) vulnerability in Apache ActiveMQ 5.x before 5.10.1 allows remote consumers to have unspecified impact via vectors involving an XPath based selector when dequeuing XML messages.

Record
DEBIAN-CVE-2014-3600
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-4vhf-2hv7-8mrx 9.8

Improper Restriction of XML External Entity Reference in Apache ActiveMQ

XML external entity (XXE) vulnerability in Apache ActiveMQ 5.x before 5.10.1 allows remote consumers to have unspecified impact via vectors involving an XPath based selector when dequeuing XML messages.

Record
GHSA-4vhf-2hv7-8mrx
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-611
Updated
2026-11-02
OSVUBUNTU-CVE-2014-3600 9.8

XML external entity (XXE) vulnerability in Apache ActiveMQ 5.x before 5.10.1 allows remote consumers to have unspecified impact via vectors involving an XPath based selector when dequeuing XML messages.

Record
UBUNTU-CVE-2014-3600
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.activemq:activemq-client
Maven
5.0.0 up to 5.10.1
5.10.1
org.apache.activemq:activemq-broker
Maven
5.0.0 up to 5.10.1
5.10.1
activemq
Debian:12
before 5.6.0+dfsg1-4
5.6.0+dfsg1-4
activemq
Debian:13
before 5.6.0+dfsg1-4
5.6.0+dfsg1-4
org.apache.activemq:activemq-client
Maven
5.0.0 up to 5.10.1, plus listed versions
5.10.05.8.05.9.05.9.1
5.10.1
org.apache.activemq:activemq-broker
Maven
5.0.0 up to 5.10.1, plus listed versions
5.10.05.8.05.9.05.9.1
5.10.1
activemq
Ubuntu:14.04:LTS
before 5.6.0+dfsg-1+deb7u1build0.14.04.1, plus listed versions
5.6.0+dfsg-1
5.6.0+dfsg-1+deb7u1build0.14.04.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2014-3600 is a critical vulnerability (CVSS 9.8) in Apache Activemq, published October 27, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.18%, the 94th percentile. Fixed in org.apache.activemq:activemq-client 5.10.1.

References

Show 8 moreShow less
MoveEnter Open