CVE-2015-3198
The Undertow module of WildFly allows source code disclosure
The Undertow module of WildFly 9.x before 9.0.0.CR2 and 10.x before 10.0.0.Alpha1 allows remote attackers to obtain the source code of a JSP page via a "/" at the end of a URL.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
The Undertow module of WildFly 9.x before 9.0.0.CR2 and 10.x before 10.0.0.Alpha1 allows remote attackers to obtain the source code of a JSP page via a "/" at the end of a URL.
- Record
CVE-2015-3198- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
The Undertow module of WildFly 9.x before 9.0.0.CR2 and 10.x before 10.0.0.Alpha1 allows remote attackers to obtain the source code of a JSP page via a "/" at the end of a URL.
- Record
CVE-2015-3198- Updated
- 2026-11-02
EUVDEUVD-2022-2454 No score
The Undertow module of WildFly 9.x before 9.0.0.CR2 and 10.x before 10.0.0.Alpha1 allows remote attackers to obtain the source code of a JSP page via a "/" at the end of a URL.
- Record
EUVD-2022-2454- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4vwv-x3gp-2j4g
7.5
The Undertow module of WildFly allows source code disclosure
The Undertow module of WildFly versions 8.1.0.Final, 8.2.0.Final, 9.0.0.CR1 allows remote attackers to obtain the source code of a JSP page via a "/" at the end of a URL.
- Record
GHSA-4vwv-x3gp-2j4g- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSVGHSA-4vwv-x3gp-2j4g
7.5
The Undertow module of WildFly allows source code disclosure
The Undertow module of WildFly versions 8.1.0.Final, 8.2.0.Final, 9.0.0.CR1 allows remote attackers to obtain the source code of a JSP page via a "/" at the end of a URL.
- Record
GHSA-4vwv-x3gp-2j4g- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.wildfly:wildfly-parentMaven |
8.1.0.Final to 9.0.0.CR1 | 9.0.0.CR2 |
org.wildfly:wildfly-parentMaven |
8.1.0.Final up to 9.0.0.CR2, plus listed versions 8.2.0.Final8.2.1.Final9.0.0.Alpha19.0.0.Beta19.0.0.Beta29.0.0.CR1 |
9.0.0.CR2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2015-3198 is a high vulnerability (CVSS 7.5) in Redhat Jboss Wildfly Application Server, published July 21, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.76%, the 78th percentile. Fixed in org.wildfly:wildfly-parent 9.0.0.CR2.