CVE-2017-2642
Moodle User fullname disclosure on user preferences page
Moodle 3.x has user fullname disclosure on the user preferences page.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
Moodle 3.x has user fullname disclosure on the user preferences page.
- Record
CVE-2017-2642- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
Moodle 3.x has user fullname disclosure on the user preferences page.
- Record
CVE-2017-2642- Updated
- 2026-11-02
EUVDEUVD-2022-2497 No score
Moodle 3.x has user fullname disclosure on the user preferences page.
- Record
EUVD-2022-2497- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-54r2-r67g-fr9m
6.5
Moodle User fullname disclosure on user preferences page
Moodle 3.x has user fullname disclosure on the user preferences page.
- Record
GHSA-54r2-r67g-fr9m- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSV
6.5
Moodle 3.x has user fullname disclosure on the user preferences page.
- Record
CVE-2017-2642- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-54r2-r67g-fr9m
6.5
Moodle User fullname disclosure on user preferences page
Moodle 3.x has user fullname disclosure on the user preferences page.
- Record
GHSA-54r2-r67g-fr9m- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2017-2642
6.5
Moodle 3.x has user fullname disclosure on the user preferences page.
- Record
UBUNTU-CVE-2017-2642- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
3.1 up to 3.1.7 | 3.1.7 |
moodle/moodlePackagist |
3.2 up to 3.2.4 | 3.2.4 |
moodle/moodlePackagist |
3.3 up to 3.3.1 | 3.3.1 |
moodle/moodlePackagist |
3.1 up to 3.1.7, plus listed versions v3.1.0v3.1.0-betav3.1.0-rc1v3.1.0-rc2v3.1.1 Show 5 moreShow lessv3.1.2v3.1.3v3.1.4v3.1.5v3.1.6 |
3.1.7 |
moodle/moodlePackagist |
3.2 up to 3.2.4, plus listed versions v3.2.0v3.2.0-betav3.2.0-rc1v3.2.0-rc2v3.2.0-rc3 Show 5 moreShow lessv3.2.0-rc4v3.2.0-rc5v3.2.1v3.2.2v3.2.3 |
3.2.4 |
moodle/moodlePackagist |
3.3 up to 3.3.1, plus listed versions v3.3.0v3.3.0-betav3.3.0-rc1v3.3.0-rc2v3.3.0-rc3 |
3.3.1 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2017-2642 is a medium vulnerability (CVSS 6.5) in Moodle, published July 17, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.24%, the 69th percentile. Fixed in moodle/moodle 3.1.7.