Every CVE Search/ Get API key

CVE-2013-4701

PHP OpenID Library Denial of Service vulnerability

7.5 HighFix available

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Exploit likelihood

3.00%Up 1.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Record
CVE-2013-4701
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Record
CVE-2013-4701
Updated
2026-11-02
EUVDEUVD-2022-2640 No score

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Record
EUVD-2022-2640
Updated
2026-11-03
GitHub AdvisoriesGHSA-5qp6-78pr-gv8c No score

PHP OpenID Library Denial of Service vulnerability

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Record
GHSA-5qp6-78pr-gv8c
Weakness
CWE-400
Updated
2026-11-02
OSVGHSA-5qp6-78pr-gv8c No score

PHP OpenID Library Denial of Service vulnerability

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Record
GHSA-5qp6-78pr-gv8c
Weakness
CWE-400
Updated
2026-11-02
OSVMGASA-2013-0272 No score

Updated php-pear-Auth_OpenID package fixes security vulnerability

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue (CVE-2013-4701).

Record
MGASA-2013-0272
Updated
2026-11-02
OSVUBUNTU-CVE-2013-4701 No score

Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Record
UBUNTU-CVE-2013-4701
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openid/php-openid
Packagist
before 2.3.0
2.3.0
typo3/cms
Packagist
6.2.0 up to 6.2.6
6.2.6
typo3/cms
Packagist
6.2.0 up to 6.2.6, plus listed versions
6.2.16.2.26.2.36.2.46.2.5
6.2.6
php-pear-Auth_OpenID
Mageia:2
before 2.2.2-1.mga2
2.2.2-1.mga2
php-pear-Auth_OpenID
Mageia:3
before 2.2.2-1.mga3
2.2.2-1.mga3

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-4701 is a high vulnerability (CVSS 7.5) in Janrain Php-openid, published August 21, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.00%, the 87th percentile. Fixed in openid/php-openid 2.3.0.

References

Show 10 moreShow less
MoveEnter Open