CVE-2019-3849
Moodle Users could elevate their role when accessing the LTI tool on a provider site
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Users could assign themselves an escalated role within courses or content accessed via LTI, by modifying the request to the LTI publisher site.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
6.3
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Users could assign themselves an escalated role within courses or content accessed via LTI, by modifying the request to the LTI publisher site.
- Record
CVE-2019-3849- CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2022-2666
6.3
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Users could assign themselves an escalated role within courses or content accessed via LTI, by modifying the request to the LTI publisher site.
- Record
EUVD-2022-2666- CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5wg9-5w3f-hxmh
8.8
Moodle Users could elevate their role when accessing the LTI tool on a provider site
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Users could assign themselves an escalated role within courses or content accessed via LTI, by modifying the request to the LTI publisher site.
- Record
GHSA-5wg9-5w3f-hxmh- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
NVD
8.8
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Users could assign themselves an escalated role within courses or content accessed via LTI, by modifying the request to the LTI publisher site.
- Record
CVE-2019-3849- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-285, CWE-269
- Updated
- 2026-11-02
OSV
8.8
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Users could assign themselves an escalated role within courses or content accessed via LTI, by modifying the request to the LTI publisher site.
- Record
CVE-2019-3849- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-5wg9-5w3f-hxmh
8.8
Moodle Users could elevate their role when accessing the LTI tool on a provider site
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Users could assign themselves an escalated role within courses or content accessed via LTI, by modifying the request to the LTI publisher site.
- Record
GHSA-5wg9-5w3f-hxmh- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
before 3.4.8 | 3.4.8 |
moodle/moodlePackagist |
3.5 up to 3.5.5 | 3.5.5 |
moodle/moodlePackagist |
3.6 up to 3.6.3 | 3.6.3 |
moodle/moodlePackagist |
before 3.4.8, plus listed versions v2.3.10v2.3.11v2.3.4v2.3.5v2.3.6 Show 45 moreShow lessv2.3.7v2.3.8v2.3.9v2.4.0v2.4.0-rc1v2.4.1v2.4.10v2.4.11v2.4.2v2.4.3v2.4.4v2.4.5v2.4.6v2.4.7v2.4.8v2.4.9v2.5.0v2.5.0-betav2.5.0-rc1v2.5.1v2.5.2v2.5.3v2.5.4v2.5.5v2.5.6v2.5.7v2.5.8v2.5.9v2.6.0v2.6.0-betav2.6.0-rc1v2.6.1v2.6.10v2.6.11v2.6.2v2.6.3v2.6.4v2.6.5v2.6.6v2.6.7v2.6.8v2.6.9v2.7.0v2.7.0-betav2.7.0-rc1 |
3.4.8 |
moodle/moodlePackagist |
3.5 up to 3.5.5, plus listed versions v3.5.0v3.5.0-betav3.5.0-rc1v3.5.1v3.5.2v3.5.3v3.5.4 |
3.5.5 |
moodle/moodlePackagist |
3.6 up to 3.6.3, plus listed versions v3.6.0v3.6.0-betav3.6.0-rc1v3.6.0-rc2v3.6.0-rc3v3.6.1v3.6.2 |
3.6.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-3849 is a medium vulnerability (CVSS 6.3) in [unknown] Moodle, published March 26, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.02%, the 63rd percentile. Fixed in moodle/moodle 3.4.8.
References
bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3849
moodle.org/mod/forum/discuss.php?d=384012
nvd.nist.gov/vuln/detail/CVE-2019-3849
github.com/moodle/moodle/commit/427463a52574e4b3bcbe1c65c49066438770641e
github.com/moodle/moodle/commit/430f685834cef190bdf58afabe79e765d596890d
github.com/moodle/moodle/commit/723d1a747555b795ed53a0fad01da455797bb78f
Show 6 moreShow less
github.com/moodle/moodle/commit/898d5d05a0c3ae6795db0241bf3cb5951213d45c
github.com/moodle/moodle/commit/b77dcd23d8e39265b5c096f0d947764c02d832c8
github.com/moodle/moodle/commit/cd3060d941a051931eb2613b25bafb0108665895
github.com/moodle/moodle/commit/fba7dcd90abd45210d782a79c6e25bb3840c7438
github.com/advisories/GHSA-5wg9-5w3f-hxmh
github.com/moodle/moodle
Left out here: 130 versions. The JSON record has them.