Every CVE Search/ Get API key

CVE-2022-22728

libapreq2 multipart form parse memory corruption

7.5 HighFix available

A flaw in Apache libapreq2 versions 2.16 and earlier could cause a buffer overflow while processing multipart form uploads. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

5.92%Up 4.9 points since Aug 26, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

A flaw in Apache libapreq2 versions 2.16 and earlier could cause a buffer overflow while processing multipart form uploads. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
CVE-2022-22728
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-120
Updated
2026-11-02
CVE List No score

libapreq2 multipart form parse memory corruption

A flaw in Apache libapreq2 versions 2.16 and earlier could cause a buffer overflow while processing multipart form uploads. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
CVE-2022-22728
Weakness
CWE-120
Updated
2026-11-02
EUVDEUVD-2022-27871 No score

A flaw in Apache libapreq2 versions 2.16 and earlier could cause a buffer overflow while processing multipart form uploads. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
EUVD-2022-27871
Updated
2026-11-03
GitHub AdvisoriesGHSA-jq3x-hcjw-4j6x 7.5

A flaw in Apache libapreq2 versions 2.16 and earlier could cause a buffer overflow while...

A flaw in Apache libapreq2 versions 2.16 and earlier could cause a buffer overflow while processing multipart form uploads. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
GHSA-jq3x-hcjw-4j6x
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-120
Updated
2026-11-02
OSV 7.5

A flaw in Apache libapreq2 versions 2.16 and earlier could cause a buffer overflow while processing multipart form uploads. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
CVE-2022-22728
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2022-22728 7.5

A flaw in Apache libapreq2 versions 2.16 and earlier could cause a buffer overflow while processing multipart form uploads. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
DEBIAN-CVE-2022-22728
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVUBUNTU-CVE-2022-22728 7.5

A flaw in Apache libapreq2 versions 2.16 and earlier could cause a buffer overflow while processing multipart form uploads. A remote attacker could send a request causing a process crash which could lead to a denial of service attack.

Record
UBUNTU-CVE-2022-22728
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2023-0123 No score

Updated libapreq2 packages fix security vulnerability

A flaw in Apache libapreq2 versions 2.16 and earlier could cause a buffer overflow while processing multipart form uploads. A remote attacker could send a request causing a process crash which could lead to a denial of service attack. (CVE-2022-22728)

Record
MGASA-2023-0123
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libapreq2
Debian:13
before 2.17-1
2.17-1
libapreq2
Debian:10
before 2.13-7~deb10u2, plus listed versions
2.13-52.13-62.13-7~deb10u12.13-7~deb9u1
2.13-7~deb10u2
libapreq2
Mageia:8
before 2.130.0-31.1.mga8
2.130.0-31.1.mga8
libapreq2
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
2.13-2.12.13-2.1build12.13-32.13-3ubuntu22.13-3ubuntu2+esm1
None known
libapreq2
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.13-4ubuntu12.13-4ubuntu22.13-4ubuntu2+esm1
None known
libapreq2
Ubuntu:18.04:LTS
All versions, plus listed versions
2.13-5build22.13-5build32.13-7~deb10u1build0.18.04.1
None known
libapreq2
Ubuntu:20.04:LTS
All versions, plus listed versions
2.13-5build42.13-5build52.13-7
None known
libapreq2
Ubuntu:22.04:LTS
All versions, plus listed versions
2.13-7build12.13-7build2
None known
libapreq2
Ubuntu:24.04:LTS
All versions, plus listed versions
2.17-32.17-3build12.17-5build12.17-5build2
None known
libapreq2
Ubuntu:25.10
All versions, plus listed versions
2.17-7
None known
libapreq2
Ubuntu:26.10
All versions, plus listed versions
2.17-82.17-92.17-9build1
None known
libapreq2
Ubuntu:26.04:LTS
All versions, plus listed versions
2.17-72.17-8
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-22728 is a high vulnerability (CVSS 7.5) in Apache Libapreq2, published August 25, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.92%, the 93rd percentile. Fixed in libapreq2 2.17-1.

References

Show 22 moreShow less
MoveEnter Open