Every CVE Search/ Get API key

CVE-2017-2578

Moodle Cross-site Scripting in assignment submission page

6.1 MediumFix available

In Moodle 3.x, there is XSS in the assignment submission page.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.86%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

In Moodle 3.x, there is XSS in the assignment submission page.

Record
CVE-2017-2578
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

In Moodle 3.x, there is XSS in the assignment submission page.

Record
CVE-2017-2578
Updated
2026-11-02
EUVDEUVD-2022-2854 No score

In Moodle 3.x, there is XSS in the assignment submission page.

Record
EUVD-2022-2854
Updated
2026-11-03
GitHub AdvisoriesGHSA-6r76-f8c8-fh7p 6.1

Moodle Cross-site Scripting in assignment submission page

In Moodle 3.x, there is Cross-site Scripting in the assignment submission page.

Record
GHSA-6r76-f8c8-fh7p
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

In Moodle 3.x, there is XSS in the assignment submission page.

Record
CVE-2017-2578
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-6r76-f8c8-fh7p 6.1

Moodle Cross-site Scripting in assignment submission page

In Moodle 3.x, there is Cross-site Scripting in the assignment submission page.

Record
GHSA-6r76-f8c8-fh7p
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2017-2578 6.1

In Moodle 3.x, there is XSS in the assignment submission page.

Record
UBUNTU-CVE-2017-2578
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
3.1 up to 3.1.4
3.1.4
moodle/moodle
Packagist
3.2 up to 3.2.1
3.2.1
moodle/moodle
Packagist
3.1 up to 3.1.4, plus listed versions
v3.1.0v3.1.0-betav3.1.0-rc1v3.1.0-rc2v3.1.1v3.1.2v3.1.3
3.1.4
moodle/moodle
Packagist
3.2 up to 3.2.1, plus listed versions
v3.2.0v3.2.0-betav3.2.0-rc1v3.2.0-rc2v3.2.0-rc3v3.2.0-rc4v3.2.0-rc5
3.2.1
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2017-2578 is a medium vulnerability (CVSS 6.1) in Moodle, published January 20, 2017. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.86%, the 58th percentile. Fixed in moodle/moodle 3.1.4.

References

MoveEnter Open