Every CVE Search/ Get API key

CVE-2013-7371

Node Connect Reflected Cross-Site Scripting in Sencha Labs Connect middleware

6.1 MediumFix available

node-connects before 2.8.2 has cross site scripting in Sencha Labs Connect middleware (vulnerability due to incomplete fix for CVE-2013-7370)

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.44%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

node-connects before 2.8.2 has cross site scripting in Sencha Labs Connect middleware (vulnerability due to incomplete fix for CVE-2013-7370)

Record
CVE-2013-7371
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

node-connects before 2.8.2 has cross site scripting in Sencha Labs Connect middleware (vulnerability due to incomplete fix for CVE-2013-7370)

Record
CVE-2013-7371
Updated
2026-11-02
EUVDEUVD-2022-2867 No score

node-connects before 2.8.2 has cross site scripting in Sencha Labs Connect middleware (vulnerability due to incomplete fix for CVE-2013-7370)

Record
EUVD-2022-2867
Updated
2026-11-03
GitHub AdvisoriesGHSA-6w62-83g6-rfhj 6.1

Node Connect Reflected Cross-Site Scripting in Sencha Labs Connect middleware

node-connect before 2.8.2 has cross site scripting in Sencha Labs Connect middleware (vulnerability due to incomplete fix for CVE-2013-7370)

Overview

Connect is a stack of middleware that is executed in order in each request.

The "methodOverride" middleware allows the http post to override the method of the request with the value of the "_method" post key or with the header "x-http-method-override".

Because the user post input was not checked, req.method could contain any kind of value. Because the req.method did not match any common method VERB, connect answered with a 404 page containing the "Cannot [method] [url]" content. The method was not properly encoded for output in the browser.

Example:

~ curl "localhost:3000" -d "_method=<script src=http://nodesecurity.io/xss.js></script>"
Cannot <SCRIPT SRC=HTTP://NODESECURITY.IO/XSS.JS></SCRIPT> /

Recommendation

Update to the newest version of Connect or disable methodOverride. It is not possible to avoid the vulnerability if you have enabled this middleware in the top of your stack.

Credit:

Sergio Arcos

Record
GHSA-6w62-83g6-rfhj
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-6w62-83g6-rfhj 6.1

Node Connect Reflected Cross-Site Scripting in Sencha Labs Connect middleware

node-connect before 2.8.2 has cross site scripting in Sencha Labs Connect middleware (vulnerability due to incomplete fix for CVE-2013-7370)

Overview

Connect is a stack of middleware that is executed in order in each request.

The "methodOverride" middleware allows the http post to override the method of the request with the value of the "_method" post key or with the header "x-http-method-override".

Because the user post input was not checked, req.method could contain any kind of value. Because the req.method did not match any common method VERB, connect answered with a 404 page containing the "Cannot [method] [url]" content. The method was not properly encoded for output in the browser.

Example:

~ curl "localhost:3000" -d "_method=<script src=http://nodesecurity.io/xss.js></script>"
Cannot <SCRIPT SRC=HTTP://NODESECURITY.IO/XSS.JS></SCRIPT> /

Recommendation

Update to the newest version of Connect or disable methodOverride. It is not possible to avoid the vulnerability if you have enabled this middleware in the top of your stack.

Credit:

Sergio Arcos

Record
GHSA-6w62-83g6-rfhj
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2013-7371 6.1

node-connects before 2.8.2 has cross site scripting in Sencha Labs Connect middleware (vulnerability due to incomplete fix for CVE-2013-7370)

Record
UBUNTU-CVE-2013-7371
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVCLSA-2026-1792476098 No score

TuxCare security update for connect (3 CVEs)

TuxCare rebuilt connect to address 3 CVEs. Fixed in 2.7.11-tuxcare.1.

Record
CLSA-2026-1792476098
Updated
2026-11-02
OSVCLSA-2026-1792508732 No score

TuxCare security update for connect (3 CVEs)

TuxCare rebuilt connect to address 3 CVEs. Fixed in 2.7.10-tuxcare.1.

Record
CLSA-2026-1792508732
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
connect
npm
before 2.8.2
2.8.2
connect
TuxCare:npm
2.7.11-tuxcare.0 up to 2.7.11-tuxcare.1, plus listed versions
2.7.11
2.7.11-tuxcare.1
connect
TuxCare:npm
2.7.10-tuxcare.0 up to 2.7.10-tuxcare.1, plus listed versions
2.7.10
2.7.10-tuxcare.1

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2013-7371 is a medium vulnerability (CVSS 6.1) in Node-connect, published December 11, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.44%, the 73rd percentile. Fixed in connect 2.8.2.

References

Show 8 moreShow less
MoveEnter Open