Every CVE Search/ Get API key

CVE-2022-24706

Remote Code Execution Vulnerability in Packaging

9.8 CriticalIn KEVPublic exploitFix available

In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default installation without authenticating and gain admin privileges. The CouchDB documentation has always made recommendations for properly securing an installation, including recommending using a firewall in front of all CouchDB installations.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

92.5%Up 91.6 points since Apr 27, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default installation without authenticating and gain admin privileges. The CouchDB documentation has always made recommendations for properly securing an installation, including recommending using a firewall in front of all CouchDB installations.

Record
CVE-2022-24706
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
10.0 HighAV:N/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-1188
Updated
2026-11-02
CVE List 9.8

Remote Code Execution Vulnerability in Packaging

In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default installation without authenticating and gain admin privileges. The CouchDB documentation has always made recommendations for properly securing an installation, including recommending using a firewall in front of all CouchDB installations.

Record
CVE-2022-24706
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1188
Updated
2026-11-02
EUVDEUVD-2022-29572 9.8

In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default installation without authenticating and gain admin privileges. The CouchDB documentation has always made recommendations for properly securing an installation, including recommending using a firewall in front of all CouchDB installations.

Record
EUVD-2022-29572
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-vxc9-8m8h-9cp6 9.8

In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default...

In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default installation without authenticating and gain admin privileges. The CouchDB documentation has always made recommendations for properly securing an installation, including recommending using a firewall in front of all CouchDB installations.

Record
GHSA-vxc9-8m8h-9cp6
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1188
Updated
2026-11-02
CISA KEV No score

Apache CouchDB Insecure Default Initialization of Resource Vulnerability

Apache CouchDB contains an insecure default initialization of resource vulnerability which can allow an attacker to escalate to administrative privileges.

Record
CVE-2022-24706
Weakness
CWE-1188
Updated
2026-11-02
OSV 9.8

Remote Code Execution Vulnerability in Packaging

In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default installation without authenticating and gain admin privileges. The CouchDB documentation has always made recommendations for properly securing an installation, including recommending using a firewall in front of all CouchDB installations.

Record
CVE-2022-24706
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-1188
Updated
2026-11-02
OSVBIT-couchdb-2022-24706 No score

Remote Code Execution Vulnerability in Packaging

In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default installation without authenticating and gain admin privileges. The CouchDB documentation has always made recommendations for properly securing an installation, including recommending using a firewall in front of all CouchDB installations.

Record
BIT-couchdb-2022-24706
Updated
2026-11-02
OSVMGASA-2022-0466 No score

Updated couchdb packages fix security vulnerability

In Apache CouchDB prior to 3.2.2, an attacker can access an improperly secured default installation without authenticating and gain admin privileges. The CouchDB documentation has always made recommendations for properly securing an installation, including recommending using a firewall in front of all CouchDB installations. (CVE-2022-24706)

Record
MGASA-2022-0466
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
couchdb
Bitnami
before 3.2.2
3.2.2
couchdb
Mageia:8
before 3.2.2-1.mga8
3.2.2-1.mga8

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
exploitation, exploits
first indexedCVE List, EUVD, Exploit-DB, GitHub Advisories, CISA KEV, Metasploit, Nuclei, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-24706 is a critical vulnerability (CVSS 9.8) in Apache Couchdb, published April 26, 2022. CISA lists it as known to be exploited, since August 25, 2022. EUVD reports exploitation since August 25, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 92.5%, the 99th percentile. Fixed in couchdb 3.2.2.

References

Show 11 moreShow less
MoveEnter Open