CVE-2022-0574
Improper Access Control in publify/publify
Improper Access Control in GitHub repository publify/publify prior to 9.2.8.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.3
Improper Access Control in publify/publify
Improper Access Control in GitHub repository publify/publify prior to 9.2.8.
- Record
CVE-2022-0574- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
EUVDEUVD-2022-2964
5.3
Improper Access Control in GitHub repository publify/publify prior to 9.2.8.
- Record
EUVD-2022-2964- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-79m3-q3wh-c3qm
6.5
Publify Incorrect Authorization
Improper Access Control in GitHub repository publify/publify prior to 9.2.8. Anonymous users can't view but can leave comments on an article in draft mode.
- Record
GHSA-79m3-q3wh-c3qm- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
NVD
6.5
Improper Access Control in GitHub repository publify/publify prior to 9.2.8.
- Record
CVE-2022-0574- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:P/I:P/A:N - Weakness
- CWE-284, CWE-863
- Updated
- 2026-11-02
OSV
5.3
Improper Access Control in publify/publify
Improper Access Control in GitHub repository publify/publify prior to 9.2.8.
- Record
CVE-2022-0574- CVSS 3.0
- 5.3 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
OSVGHSA-79m3-q3wh-c3qm
6.5
Publify Incorrect Authorization
Improper Access Control in GitHub repository publify/publify prior to 9.2.8. Anonymous users can't view but can leave comments on an article in draft mode.
- Record
GHSA-79m3-q3wh-c3qm- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-863
- Updated
- 2026-11-02
OSVBIT-publify-2022-0574 No score
Improper Access Control in GitHub repository publify/publify prior to 9.2.8.
- Record
BIT-publify-2022-0574- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
publify_coreRubyGems |
before 9.2.8 | 9.2.8 |
publifyBitnami |
before 9.2.8 | 9.2.8 |
publify_coreRubyGems |
before 9.2.8, plus listed versions 9.0.09.0.0.pre19.0.0.pre29.0.0.pre39.0.0.pre4 Show 12 moreShow less9.0.0.pre59.0.0.pre69.0.19.1.09.2.09.2.19.2.29.2.39.2.49.2.59.2.69.2.7 |
9.2.8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-0574 is a medium vulnerability (CVSS 5.3) in Publify Publify/publify, published May 16, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.84%, the 58th percentile. Fixed in publify_core 9.2.8.
References
huntr.dev/bounties/6f322c84-9e20-4df6-97e8-92bc271ede3f
github.com/publify/publify/commit/0e6c66ac2002136517662399bca9d838c80d9739
nvd.nist.gov/vuln/detail/CVE-2022-0574
github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2022-0574.yml
github.com/advisories/GHSA-79m3-q3wh-c3qm
github.com/CVEProject/cvelistV5/tree/main/cves/2022/0xxx/CVE-2022-0574.json
github.com/publify/publify