CVE-2006-1547
Improper Input Validation in Apache Struts
ActionForm in Apache Software Foundation (ASF) Struts before 1.2.9 with BeanUtils 1.7 allows remote attackers to cause a denial of service via a multipart/form-data encoded form with a parameter name that references the public getMultipartRequestHandler method, which provides further access to elements in the CommonsMultipartRequestHandler implementation and BeanUtils.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
ActionForm in Apache Software Foundation (ASF) Struts before 1.2.9 with BeanUtils 1.7 allows remote attackers to cause a denial of service via a multipart/form-data encoded form with a parameter name that references the public getMultipartRequestHandler method, which provides further access to elements in the CommonsMultipartRequestHandler implementation and BeanUtils.
- Record
CVE-2006-1547- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 7.8 High
AV:N/AC:L/Au:N/C:N/I:N/A:C - Weakness
- CWE-749
- Updated
- 2026-11-02
CVE List
7.5
ActionForm in Apache Software Foundation (ASF) Struts before 1.2.9 with BeanUtils 1.7 allows remote attackers to cause a denial of service via a multipart/form-data encoded form with a parameter name that references the public getMultipartRequestHandler method, which provides further access to elements in the CommonsMultipartRequestHandler implementation and BeanUtils.
- Record
CVE-2006-1547- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-749
- Updated
- 2026-11-02
EUVDEUVD-2022-3054
7.5
ActionForm in Apache Software Foundation (ASF) Struts before 1.2.9 with BeanUtils 1.7 allows remote attackers to cause a denial of service via a multipart/form-data encoded form with a parameter name that references the public getMultipartRequestHandler method, which provides further access to elements in the CommonsMultipartRequestHandler implementation and BeanUtils.
- Record
EUVD-2022-3054- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-7qwv-cwgj-c8rj
7.5
Improper Input Validation in Apache Struts
ActionForm in Apache Software Foundation (ASF) Struts before 1.2.9 with BeanUtils 1.7 allows remote attackers to cause a denial of service via a multipart/form-data encoded form with a parameter name that references the public getMultipartRequestHandler method, which provides further access to elements in the CommonsMultipartRequestHandler implementation and BeanUtils.
- Record
GHSA-7qwv-cwgj-c8rj- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:H - Weakness
- CWE-20, CWE-749
- Updated
- 2026-11-02
CISA KEV No score
Apache Struts 1 ActionForm Denial-of-Service Vulnerability
ActionForm in Apache Struts versions before 1.2.9 with BeanUtils 1.7 contains a vulnerability that allows for denial-of-service (DoS).
- Record
CVE-2006-1547- Updated
- 2026-11-02
OSVGHSA-7qwv-cwgj-c8rj
7.5
Improper Input Validation in Apache Struts
ActionForm in Apache Software Foundation (ASF) Struts before 1.2.9 with BeanUtils 1.7 allows remote attackers to cause a denial of service via a multipart/form-data encoded form with a parameter name that references the public getMultipartRequestHandler method, which provides further access to elements in the CommonsMultipartRequestHandler implementation and BeanUtils.
- Record
GHSA-7qwv-cwgj-c8rj- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:H - Weakness
- CWE-20, CWE-749
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
struts:strutsMaven |
before 1.2.9 | 1.2.9 |
struts:strutsMaven |
before 1.2.9, plus listed versions 1.0.21.11.1-b2-200211241.1-b31.1-beta-2 Show 6 moreShow less1.1-rc11.1-rc21.2.21.2.41.2.71.2.8 |
1.2.9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| exploitation | ||
| first indexed | CVE List, EUVD, GitHub Advisories, CISA KEV, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2006-1547 is a high vulnerability (CVSS 7.5) in Apache Struts, published March 30, 2006. CISA lists it as known to be exploited, since January 21, 2022. EUVD reports exploitation since January 21, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 54.6%, the 99th percentile. Fixed in struts:struts 1.2.9.
References
securitytracker.com/id?1015856
struts.apache.org/struts-doc-1.2.9/userGuide/release-notes.html
vupen.com/english/advisories/2006/1205
securityfocus.com/bid/17342
secunia.com/advisories/19493
exchange.xforce.ibmcloud.com/vulnerabilities/25613
Show 7 moreShow less
lists.suse.com/archive/suse-security-announce/2006-May/0004.html
secunia.com/advisories/20117
issues.apache.org/bugzilla/show_bug.cgi?id=38534
cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2006-1547
nvd.nist.gov/vuln/detail/CVE-2006-1547
github.com/advisories/GHSA-7qwv-cwgj-c8rj
github.com/apache/struts