Every CVE Search/ Get API key

CVE-2022-26127

A buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the...

7.8 HighFix available

A buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the input packet length in the babel_packet_examin function in babeld/message.c.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.01%Up 0.1 points since Mar 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

A buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the input packet length in the babel_packet_examin function in babeld/message.c.

Record
CVE-2022-26127
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119, CWE-1284
Updated
2026-11-02
CVE List No score

A buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the input packet length in the babel_packet_examin function in babeld/message.c.

Record
CVE-2022-26127
Weakness
CWE-119
Updated
2026-11-02
EUVDEUVD-2022-30694 No score

A buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the input packet length in the babel_packet_examin function in babeld/message.c.

Record
EUVD-2022-30694
Updated
2026-11-02
GitHub AdvisoriesGHSA-5xgr-wq7f-67xj 7.8

A buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the...

A buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the input packet length in the babel_packet_examin function in babeld/message.c.

Record
GHSA-5xgr-wq7f-67xj
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119, CWE-1284
Updated
2026-11-02
OSVALPINE-CVE-2022-26127 7.8

A buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the input packet length in the babel_packet_examin function in babeld/message.c.

Record
ALPINE-CVE-2022-26127
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSVDEBIAN-CVE-2022-26127 7.8

A buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the input packet length in the babel_packet_examin function in babeld/message.c.

Record
DEBIAN-CVE-2022-26127
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
Show 6 moreShow less
OSVUBUNTU-CVE-2022-26127 7.8

A buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the input packet length in the babel_packet_examin function in babeld/message.c.

Record
UBUNTU-CVE-2022-26127
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV No score

A buffer overflow vulnerability exists in FRRouting through 8.1.0 due to missing a check on the input packet length in the babel_packet_examin function in babeld/message.c.

Record
CVE-2022-26127
Weakness
CWE-119
Updated
2026-11-02
OSVopenSUSE-SU-2022:0901-1 No score

Security update for frr

This update for frr fixes the following issues:

  • CVE-2022-26125, CVE-2022-26126: Fixed buffer overflows in unpack_tlv_router_cap() (bsc#1196505, bsc#1196506).
  • CVE-2022-26127: Fixed heap buffer overflow in babel_packet_examin() (bsc#1196503).
  • CVE-2022-26128: Fixed buffer overflows in babel_packet_examin() (bsc#1196507).
  • CVE-2022-26129: Fixed buffer overflows in parse_hello_subtlv(), parse_ihu_subtlv() and parse_update_subtlv() (bsc#1196504).
Record
openSUSE-SU-2022:0901-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11880-1 No score

frr-8.1-3.1 on GA media

These are all security issues fixed in the frr-8.1-3.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11880-1
Updated
2026-11-02
OSVSUSE-SU-2022:0901-1 No score

Security update for frr

This update for frr fixes the following issues:

  • CVE-2022-26125, CVE-2022-26126: Fixed buffer overflows in unpack_tlv_router_cap() (bsc#1196505, bsc#1196506).
  • CVE-2022-26127: Fixed heap buffer overflow in babel_packet_examin() (bsc#1196503).
  • CVE-2022-26128: Fixed buffer overflows in babel_packet_examin() (bsc#1196507).
  • CVE-2022-26129: Fixed buffer overflows in parse_hello_subtlv(), parse_ihu_subtlv() and parse_update_subtlv() (bsc#1196504).
Record
SUSE-SU-2022:0901-1
Updated
2026-11-02
OSVUSN-6807-1 No score

frr vulnerabilities

It was discovered that FRR incorrectly handled certain network traffic. A remote attacker could possibly use this issue to cause FRR to crash, resulting in a denial of service. (CVE-2022-26126, CVE-2022-26127, CVE-2022-26128, CVE-2022-26129, CVE-2022-37032, CVE-2022-37035, CVE-2023-31490, CVE-2023-38406, CVE-2023-38407, CVE-2023-46752, CVE-2023-46753, CVE-2023-47234, CVE-2023-47235, CVE-2024-31948)

Ben Cartwright-Cox discovered that FRR incorrectly handled certain network traffic. A remote attacker could possibly use this issue to cause FRR to crash, resulting in a denial of service. (CVE-2023-38802)

Record
USN-6807-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
frr
Alpine:v3.16
before 8.2.1-r0
8.2.1-r0
frr
Alpine:v3.17
before 8.2.1-r0
8.2.1-r0
frr
Alpine:v3.18
before 8.2.1-r0
8.2.1-r0
frr
Alpine:v3.19
before 8.2.1-r0
8.2.1-r0
frr
Alpine:v3.20
before 8.2.1-r0
8.2.1-r0
frr
Alpine:v3.21
before 8.2.1-r0
8.2.1-r0
frr
Alpine:v3.22
before 8.2.1-r0
8.2.1-r0
frr
Alpine:v3.23
before 8.2.1-r0
8.2.1-r0
frr
Alpine:v3.24
before 8.2.1-r0
8.2.1-r0
frr
Debian:12
before 8.4.1-1
8.4.1-1
Show 9 moreShow less
Affected packages
PackageAffectedFixed
frr
Debian:13
before 8.4.1-1
8.4.1-1
frr
Debian:14
before 8.4.1-1
8.4.1-1
frr
Debian:10
before 7.5.1-1.1+deb10u2, plus listed versions
6.0.2-26.0.2-2+deb10u16.0.2-2+deb10u27.2-17.2.1-1
Show 8 moreShow less
7.3.1-17.4-17.4-1.17.4-27.5-17.5.1-17.5.1-1.17.5.1-1.1+deb10u1
7.5.1-1.1+deb10u2
frr
Debian:11
before 7.5.1-1.1+deb11u3, plus listed versions
7.5.1-1.17.5.1-1.1+deb11u17.5.1-1.1+deb11u2
7.5.1-1.1+deb11u3
frr
SUSE:Linux Enterprise Module for Server Applications 15 SP3
before 7.4-150300.4.3.1
7.4-150300.4.3.1
frr
Ubuntu:Pro:20.04:LTS
before 7.2.1-1ubuntu0.2+esm2, plus listed versions
6.0.2-2build27.2-1ubuntu17.2-1ubuntu27.2.1-17.2.1-1ubuntu0.17.2.1-1ubuntu0.27.2.1-1ubuntu0.2+esm1
7.2.1-1ubuntu0.2+esm2
frr
Ubuntu:22.04:LTS
before 8.1-1ubuntu1, plus listed versions
7.5.1-1.18.1-1
8.1-1ubuntu1
frr
openSUSE:Leap 15.3
before 7.4-150300.4.3.1
7.4-150300.4.3.1
frr
openSUSE:Tumbleweed
before 8.1-3.1
8.1-3.1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-26127 is a high vulnerability (CVSS 7.8) in Frrouting, published March 3, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in frr 8.2.1-r0.

References

Show 32 moreShow less
MoveEnter Open