Every CVE Search/ Get API key

CVE-2010-1616

Moodle is vulnerable to unauthorized new accounts creation

4.0 MediumFix available

Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they do not have the moodle/user:create capability.

Exploit likelihood

1.17%Up 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they do not have the moodle/user:create capability.

Record
CVE-2010-1616
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they do not have the moodle/user:create capability.

Record
CVE-2010-1616
Updated
2026-11-02
EUVDEUVD-2022-3298 No score

Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they do not have the moodle/user:create capability.

Record
EUVD-2022-3298
Updated
2026-11-03
GitHub AdvisoriesGHSA-966m-m549-2878 No score

Moodle is vulnerable to unauthorized new accounts creation

Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they do not have the moodle/user:create capability.

Record
GHSA-966m-m549-2878
Weakness
CWE-284
Updated
2026-11-02
OSVGHSA-966m-m549-2878 No score

Moodle is vulnerable to unauthorized new accounts creation

Moodle 1.8.x and 1.9.x before 1.9.8 can create new roles when restoring a course, which allows teachers to create new accounts even if they do not have the moodle/user:create capability.

Record
GHSA-966m-m549-2878
Weakness
CWE-284
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
1.8.0 up to 1.8.12
1.8.12
moodle/moodle
Packagist
1.9.0 up to 1.9.8
1.9.8
moodle
Debian:5.0
From an advisory covering 13 CVEs
before 1.8.13-1, plus listed versions
1.8.2.dfsg-31.8.2.dfsg-3+lenny11.8.2.dfsg-3+lenny21.8.2.dfsg-3+lenny31.8.2.dfsg-4
Show 4 moreShow less
1.8.2.dfsg-51.8.2.dfsg-5.11.8.2.dfsg-61.8.2.dfsg-6.1
1.8.13-1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2010-1616 is a medium vulnerability (CVSS 4.0) in Moodle, published April 29, 2010. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.17%, the 67th percentile. Fixed in moodle/moodle 1.8.12.

References

Show 6 moreShow less
MoveEnter Open